1

SharePoint 2013 Search Service not showing search results. Below is the error details.

An error occurred while receiving the HTTP response to https://myQueryProcessingServer:32844/feb50aff5b52475ba00ffec8d8e1adff/SearchService.svc. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down). See server logs for more details.

Below is the error screenshot.

enter image description here

Search service is crawling fine and all components are UP in the Search Administration.

Any help?

  • Is your Search Service Application in the web application service connection list? – Matthew McDermott Apr 11 '17 at 10:14
  • Yes it is. I have tried creating new search service and it worked fine. But still i want to troubleshoot and fix the error of above service as recreating is not the solution. – Muhammad Zeeshan Tahir Apr 11 '17 at 10:37
1

Try running the Srx reports on your farm to determine if all services are correctly provisioned and communicating. For example, is the SQSS running on your Query Servers? SRx Core - SharePoint Search Health Reports

  • Thanks Matthew. I ran that script and it tested my Search Service. Everything appeared fine except SSAEndPointSQSS. I see error on it SSAEndPointSQSS Error {(SearchService.svc) The following WCF service Endpoints cannot be reached:, (SearchService.svc) The following WCF service Endpoints cannot be reached..... – Muhammad Zeeshan Tahir Apr 12 '17 at 9:27
  • That is what I thought. Are you running the SSQS on the Query Server(s)? If not be sure to start them. – Matthew McDermott Apr 12 '17 at 12:09
  • Yes they are already running on Query Servers which are my WFEs. – Muhammad Zeeshan Tahir Apr 12 '17 at 15:42
  • Can the services be reached? Are you running firewall rules preventing communication? You have to resolve the failures in the report. – Matthew McDermott Apr 12 '17 at 21:35
  • Yes if i manually browse the services on all servers individually, they are accessible over http and https (by showing a certificate error). I believe there is no change in Firewall rules recently. Same error i am noticing on Managed Metadata Service as well. Both services were working fine couple of days back. – Muhammad Zeeshan Tahir Apr 13 '17 at 14:58
0

After spending weeks on troubleshooting this issue, i ended up on recreating the Search Service Application using the same existing search service databases. No other workaround helped me to make my current Search usable.

P.S: Since i have not found a fix to above problem, i'll not mark it as answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.