1

I am working on a sharepoint enterprise server 2013, and i have the following:-

  1. Enterprise wiki site collection , where i have enabled friendly url for my wiki pages inside the Site Navigation settings.

  2. now i added a new wiki page which have this name "Steps to add new item inside the ERP [Main Module]"

  3. where the wiki page got the following values:-

    • Page name= Steps to add new item inside the ERP [Main Module].aspx

    • Page title= Steps to add new item inside the ERP [Main Module]

    • Navigation Term = Steps to add new item inside the ERP [Main Module]

    • Target page for the navigation term= ~sitecollection/Pages/Steps to add new item inside the ERP %5BMain Module%5D.aspx

  4. now i edit the wiki page and i change its name from "Steps to add new item inside the ERP [Main Module]" to "Steps to add new item inside the ERP (Main Module)", mainly I replace [] with (),where i got these new values:-

    • Page name = Steps to add new item inside the ERP (Main Module).aspx
    • Page title = Steps to add new item inside the ERP [Main Module]
    • Navigation Term =Steps to add new item inside the ERP [Main Module]
    • Target page for the navigation term= ~sitecollection/Pages/Steps to add new item inside the ERP %5BMain Module%5D.aspx

Now i know that updating a wiki page name will not automatically change the Page Title and the Term Name which is fine.

But the problem in my case is that since the Page name contain these 2 characters [ ] then when i changed the wiki page name the Target page for the navigation term will not be updated, and it will keep referencing the old url ( ~sitecollection/Pages/Steps to add new item inside the ERP %5BMain Module%5D.aspx in my case) which no longer exists... keeping in mind that if i add a new wiki page that do not have [ ] inside its name then the problem will not happen ,, so seems for a reason or another using [ or ] inside the wiki page name while having friendly url enabled will cause the issue..

so can anyone adivce what is going on !!

here is the Target page URL i am talking about, which can be accessed from "Site Settings" >> "Term Store Management".. enter image description here

where in normal cases updating the wiki page name, will automatically update the target page url for the navigation term,, but seems when the original wiki page name contain [ or ] the target page url will not get updated when changing the associated page name !!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.