0

When I am typing this command Register-SPWorkflowService in the SharePoint 2013 Management Shell , I get an error message saying that this command is not recognized.

I also ran this Add-PSSnapin Microsoft.SharePoint.Powershell but again the same error message

I am running the powershell window as administrator.

I am also not able to see the command when ran this command Get-Command *register*

What can be the issue here ?

Screenshot:enter image description here

1
  • What do you get when you run: get-command -module microsoft.sharepoint.powershell (that should output hundreds of cmdlets (779 on my machine)) In other words, is it just this command that's missing, or do you not have access to any of them?
    – Mike2500
    Apr 7 '17 at 12:25
3

if you do a get-command from the powershell do you see it listed in there similar to this screenshot:

enter image description here

if not then follow these process

Configuring SharePoint 2013 to support workflow Management Service y default, in SharePoint 2013, Workflow Manager Service is not configured. Workflow Manager Service has to be downloaded, installed and configured manually before it can be used in SP 2013. Here is a step by step walkthrough.

Step 1: Open Microsoft Web Platform Installer enter image description here

My version of WPI is 4.5 enter image description here

Step 2: Search for Workflow. You will get the below list enter image description here

Step 3: Select Workflow Manger 1.0, click Add and then "Install" enter image description here

Step 4: Click on "I Accept" enter image description here

Step 5: Click on "Continue"

enter image description here

Step 6: Click on "Continue" enter image description here

Step 7: Click on "Configure Workflow Manager with Custom Settings" enter image description here

Step 8: Click on all " Test Connection" buttons

enter image description here

Step 9: Supply User details and Passwords enter image description here

Step 10: Accept the defaults and check "Allow Workflow management over HTTP on this computer" option as your system is not configured for HTTPS. enter image description here

Step 11: Next task is Service Bus configuration. enter image description here

Step 12: Do test connections and select "use the same account" and "use the same certificate" options. enter image description here

enter image description here

Step 13: Accept the summary screen

enter image description here

Step 14: Now, installation in progress and it will take couple of minutes enter image description here

enter image description here

Step 15: Installation complete enter image description here

enter image description here

Step 16: Check Application Pool "WorkflowMgmtPool" running or not enter image description here

Step 17: Check web site "Workflow Management Site" running or not enter image description here

Step 18: Install Cumulative updates. First install cumulative update of Service Bus enter image description here

enter image description here

enter image description here

Step 19: Install Workflow Manager 1.0 Cumulative Update 1 enter image description here

enter image description here

Step 20: DO IISRESET enter image description here

Step 21: Workflow Service Status will still remain "Not Connected" enter image description here

Step 22: You need to register "Workflow Manger". For that, Open Management Shell as Administrator

enter image description here

Step 23: Give this command Register-SPWorkflowService -SPSite "http://xxxx" -WorkflowHostUri "http://xxxx:12291" -AllowOAuthHttp

enter image description here

Step 24: Refresh the page. Your Workflow Service Status is "connected" now.

enter image description here

Step 25: You can also verify this using SharePoint Designer. For that, connect to the server

enter image description here

Step 26: Select Workflow, click on List workflow. Check the platform type by clicking on Platform Type Selection box. You will see both SharePoint 2010 Workflow and SharePoint 2013 Workflow.

enter image description here

Good luck

7
  • Thanks for the detailed steps for installation. But still I am not able to run the command Register-SPWorkflowService
    – Karthik
    Apr 11 '17 at 4:08
  • Request you Please attach screenshot. this will help to analyze better Apr 11 '17 at 11:27
  • As I see in powershell it was "Method 'Upgrade' in type 'Microsoft.SharePoint.WorkflowServices.WorkflowServiceApplicationProxy' from assembly 'Microsoft.SharePoint.Wor Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation. " This is issue with upgrade. Please install the update, open up that PS window & you're blissfully error free. Then you will be able to register Workflow Manager. Apr 11 '17 at 12:43
  • I have installed all the updates shown in your answer, but still I am facing the issue. Please tell me which update I have to install.
    – Karthik
    Apr 12 '17 at 4:14
  • Could you please provide your SharePoint build version. To get build version go to CA>Manage servers in the farm Apr 12 '17 at 5:47
0

There are couple of reasons for this situation.

  1. You are running the command in the workflow manager pwoershell not SharePoint Powershell. This command run in the SharePoint Powershell windows.
  2. You are running this command on the sharepoint server in SharePoint powershell but dont have Workflow manager or client installed on the machine.

Check my post over here:
SharePoint Server 2016 Troubleshooting - Workflow Manager 1.0 - The Term 'Register-SPWorkflowService' Is Not Recognized

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.