3

I am using SPD 2013 to get information from a SharePoint 2013 Online list. I’m only trying to GET information, however I have not had a HTTP call work (I have made about 4 different workflows trying different approaches). The responce is always unauthorized. I have full control permission to the site and have given workflows elevated permissions via https://msdn.microsoft.com/en-us/library/office/jj822159.aspx, and placed the call into an app step but nothing changed I still get unauthorized each time.

Recently I have been working with this url: https://SharepointSite/_vti_bin/clients.svc/web/lists/getbyid(guid'926E1BC3-9D55-42FB-970F-EC125905BF24'/items. When I use Chrome’s Advanced Rest Client App for a GET call I receive a 403 Forbidden response. I have spent several days trying to get this worked out, if anyone has any incite I would be grateful.

Thanks for your help

2

Try to verify below steps

  • Is it failing because of request url or any steps before is causing error like "Log Workflow History" List. (This happend many times in our case)
  • Run the REST api url you are using in action run from the browser.
  • Try to get get item using "Get List Item" action versus "HTTP Call".

If you are trying to fetch from the list in the different site you might need to run in-app step and workflow app requires additional permissions (e.g: Scope-Site and Permissions-Read) in order to work for every one.

0

Thank you for your help! I have got my Call an HTTP Service to work after tweaking the URL some more. I was unaware that placing your URL in to your browser should direct you to an untitled SharePoint feed. I would encourage anyone having problems to try different URL’s in their browser until they don’t get the “HTTP 400 Bad Request” response.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.