I'm following this tutorial on how to add a custom/existing managed property mappings of an item template. About halfway down she mentions that after adding the property to your template you need to go to the Search results types page and click the Property Sync Update link which will magically appear there. I'm not getting the link.

I've uploaded Content Web Part, Search, and Custom item templates. I've tried both custom managed properties and some of the built-in ones that aren't normally included in the templates. And I've added the mapped properties both through the UI and also downloading and editing the html and uploading.

I've checked in the browser debugger that the generated js file includes the new mapping and that I'm not getting a cached version of the file.

I've confirmed with REST search queries that the managed properties do exist and that there are items in my search source that have values for those properties.

I've found several posts about this issue such as this one which suggest running a PowerShell, but I don't have access to that.

We have a 2013 on-prem farm and I have 10 different site collections (out of thousands on the farm). I'm currently working on a 'new' site collection, but went back to some of my older ones where I know we've done this in years past. I'm not getting the link there either. I assume this means I'll need to work with our SharePoint team?

Is there anything that can be done about this from the site-collection-owner-without-access-to-the-Get-SPEnterpriseSearchServiceApplication?

1 Answer 1


It is old question but someone may still benefit from this answer. The link to update is: javascript:SyncProperties(). You could try to execute it from the console(F12 in browser). It worked for me (but I had the link displayed). Not sure will it work if there is no link.

  • 1
    Not sure if it actually syncs the properties, but it runs and the page reloads. So long ago, but thanks for answering.
    – Rothrock
    Commented Jul 18, 2018 at 16:58
  • it does page reload after executing. Even then new added managed properties are not showing up Commented May 8, 2019 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.