1

I am using SharePoint Server 2013 And I need to create a workflow using SharePoint designer 2013. I created 2013 workflow attached to a list and it doesn't contain any errors. However, I am not able to publish it. I am receiving an error.

Any ideas?

Workflow Error

I did some researches and they required to check if the workflow management site has the port 12991, but I didn't even find it!

IIS

1

Did you install Workflow manager ?

https://technet.microsoft.com/en-us/library/jj658588.aspx

| improve this answer | |
  • I am not sure if it is installed or not since I am not the one who installed the environment, but when I created the workflow I can see workflow 2013. How can I check if it is installed correctly or not? and Should I install it? @Raf – N.Sahraoui Apr 6 '17 at 14:02
  • 1
    to check if workflow manager is installed check SharePoint 2016: Configure Workflow Manager. and Workflow Manager Health Checklist – Mohamed El-Qassas MVP Apr 6 '17 at 14:03
  • Thank you for the response, it seems that the workflow manager is not installed, I installed it and then started configure it, but I received a message: Farm managed database already configured Please I really need help!!! – N.Sahraoui Apr 6 '17 at 14:12
  • In what step of configuring you receive this message? – Raf Apr 6 '17 at 14:20
  • I tried to configure a new Farm but I got a message Farm managed database already configured, then I tried joining the computer to the Farm but I cannot find the certificate generation key!! Finally, I tried creatinhg a custom configuration (the second choice), followed all the steps but the configuration failed. I wish I could show you screen shots, I am not able to share them in the comments. Thank you @Raf – N.Sahraoui Apr 6 '17 at 16:34
3

I experienced the same issue before. and actually, the workflow was had errors but it was not visible!

So I did the following to show the errors:

  • Save and close your workflow.
  • Try to open it again.
  • Click on Check for Errors button from your ribbon.
  • All errors should now be visible.

If the issue still not solved, so try to clear the cache and update the SharePoint Designer as mentioned at Clear SharePoint Designer Cache

If the issue still persists, so try to follow the mentioned instructions at Workflow Manager Health Checklist.

You can also check other root causes and more details at The Workflow contains errors, but they are not visible in the current view


In the end, you may also need to check the workflow manager configuration as mentioned at

| improve this answer | |
  • the workflow is veru simple and I tested it in another environment and everything is working fine. I just want to send an email notification when an item is added. However, I checked the IIS and I didn't finf the workflow management site I edit the post and add a screen shot. – N.Sahraoui Apr 6 '17 at 13:37
0

I finally uninstall the Workflow management Server, I followed the article https://sharepointinaction.wordpress.com/2014/01/27/uninstallingremoving-sharepoint-2013-workflow-manager-farm/
Then, I reinstall it again from scratch in both servers since I have a multi Farm server using the article that @M.Qassas gave me. Make sure that when you go to central administration, click on your Web App and then connections in the ribbon, the workflow service proxy and the user profile service are checked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.