I have a Sharepoint install that is functioning as an extranet. We have been creating accounts for our partners and allowing them into the site.

I would like to hide our staff's phone numbers from viewing by anyone except themselves.

To accomplish this, I went to Manage services, clicked User Profile and "Manage Properties."

I edited the work phone number property and set the Default Visibility to 'Only me.'

I then logged in using a test account. The number is still visible.

I then went to Manage User Properties. I verified that the property has the same display settings there.

I'm wondering if:

  • There is some synchronization or update action that I am not taking for the change to take effect?
  • Is there some property I have not changed in a screen I'm not seeing?

Thanks, hope someone out there has an idea because I'm stuck at this point.

  • Where are you click on the username are you directed to the user's profile or the user information list? If you click through the user's profile it will take the settings immediately, no user profile sync or search crawl required. I was unable to change the setting globally in my environment, but I was able to turn off replicate and allow overriding after which the privacy profile removed the field. Commented Oct 13, 2011 at 1:25
  • When I click on a username, I am directed to the user information list. Should I be seeing a user profile?
    – rsteckly
    Commented Oct 13, 2011 at 22:41

1 Answer 1


The User Information List uses the basic Foundation functionality and does not take the Privacy Policy into account. Clicking on a username should point to the UserDisp.aspx page but then redirect to the user's profile page.

  • Why would it not redirect? The Central Admin says I have 9 profiles but doesn't list them. Is it not redirecting because user profiles are not setup properly?
    – rsteckly
    Commented Oct 13, 2011 at 23:56
  • First thing to check would be valid Alternate Access Mappings. Do you have a full and short name? portal.acme.com and portal? If the url isn't listed this can happen. If the user doesn't have a profile, this can also happen but this shouldn't be a problem in your case. Commented Oct 14, 2011 at 0:54
  • This might help though it is for 2007: sharepoint.microsoft.com/blogs/LKuhn/Lists/Posts/… Commented Oct 14, 2011 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.