8

I have a folders within document libraries with unique permissions. I want to grant access to a particular user but when I go to grant permission I get the following message:

"Sharing folders is disabled To enable sharing, disable the limited access lockdown mode feature on the Site Features page, or share individual files or the site instead."

Should I Deactivate "Limited-access user permission lockdown mode"? And if I do what are the implications of turning this off?

Thanks a lot for your help.

1
  • 2
    paulSP20132017, I have disabled Limited-access user permission lockdown mode feature, while the SharePoint Server Publishing Infrastructure feature is active. I have not seen any issues due to this configuration, but I just did it today. Do you have any updates since your question was posted? Thanks...
    – Bob C.
    Commented Aug 30, 2017 at 23:04

2 Answers 2

6

Yes, go for it, if you're ok with:

Source: https://support.office.com/en-us/article/Enable-or-disable-site-collection-features-A2F2A5C2-093D-4897-8B7F-37F86D83DF04?ui=en-US&rs=en-US&ad=US

Limited-access user permission lockdown mode

When enabled, permissions for users with “limited access” permissions, such as Anonymous Users, are reduced, preventing access to Application pages including item properties or list views. Additionally, if a document, folder, or library has unique permissions, those users will not be able to:

Use the drag and drop feature to upload documents

Browse to the affected folder

Use the Shared with feature

Create calendar events from calendar lists connected in Outlook

Open documents in the Office client

Some callout features on documents and folders will not render as expected

2
  • @paulSP20132017 please consider marking this as answered to help the community and close this question. Commented Aug 31, 2017 at 16:40
  • So, still no actual specifics from Microsoft on what exactly the implications for "SharePoint Server Publishing" are, right?
    – Amit Naidu
    Commented Jul 25, 2018 at 21:31
2

As a workaround add user/group at site level, then on folder level stop inheriting permissions and remove user/groups not needed. Also, deactivating feature "Limited-access user permission lockdown mode" resolves the issue.

1
  • The trick to "narrow" permissions, by adding higher then removing lower, worked well for me. And I didn't have to take the risk of turning off the lockdown mode.
    – netjeff
    Commented Sep 1, 2022 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.