I have a page, with a document library in it. I want the Files and Library Tab to appear on Ribbon. But these Tabs appear only when the page is in Edit Mode, Once the page is published there is nothing in the ribbon, not even the Browse Tab It tried to use javascript, nothing worked So i noticed that, on all pages in the website, the ribbon does not appear, once the page are published. The Ribbon is available only when i'm editing the page.

Please Help.

1 Answer 1


Check whether the option is selected to allow for hiding the ribbon. Go to:

Site settings -> navigation -> at the bottom of the page you'll see "Show and Hide Ribbon". Choose which ever option you see fit for your workplace.

As far as the page goes, the ribbon may be defaulted to "hide".

Click the gear in the top right corner of the page and there should be an option for "show ribbon".

  • Hi, "Show/Hide Ribbon" is working only for site administrators, the users with Read access don't have that option. SO, by default the ribbon is hidden and they cannot change that.
    – BeckyS
    Mar 30, 2017 at 13:56
  • By default, users with "Read" permission do not have access to the ribbon. You can modified the group permissions to allow it, bernado-nguyen-hoan.com/2013/05/10/… Mar 30, 2017 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.