0

Edit is disabled and Delete option is missing Not able to edit or delete Global Navigation Items in Site navigation settings even though the user is a member of Site Owners Group. As in the below screenshot, the user is not getting delete button and edit button is disabled. Please suggest how to resolve it?

0

The behavior you are getting is because, the site is added in global navigation by SharePoint. If you scroll top in Navigation settings, you can see below settings done in it.

enter image description here

If you continue this settings, you will continue face this issue. To change the site title and URL you need to go to that site and change the settings there manually. Changes will be reflect to global navigation automatically.

enter image description here

The alternate solution for this is you deselect the "Show subsites" option and create your own heading for each site.

| improve this answer | |
  • Thanks for replying. Actually the issue is out of 4 sub-sites, one Subsite is not visible in the global navigation even for Site Owners. Can you tell me what could be the reason? – Althaf Shaik Mar 30 '17 at 9:57
  • In Site Settings-Navigation, increase the Maximum number of dynamic items in Global and Current Navigation and see if that fixes it. – mannaggia Mar 30 '17 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.