0

I've been struggling for days now. I edited a custom Master Page html file, the Javascript part. When I browse using IE, the changes are there. On Firefox and Chrome, it is not. On some PCs the changes are not there at all on all browsers. On some other PCs there are changes but only on IE. I already tried delete cache on every browsers. Still not working. Also, the html master page is not visible in the Sharepoint designer. So I had to open explorer to edit it.

I tried copying seattle master page. Then copy pasted the custom master page into the new seattle copy and rename it to something else, linked it to homepage.aspx. But that gives me 'Something went wrong' error.

  • Are you using a publishing site? If you are using Publishing site incense check it in and publish your master page HTML file and make sure you are opening the site with same credentials in all browsers. – Suriya Mar 27 '17 at 4:27
  • Yep I am using publishing site. And using the same credentials in every browsers. The javascript is still aren't the same in all browsers. It is as if there is a script or something detecting the browser and when it doesn't hit what it wants, it uses the default master page. But I can't find what it is. I found the link to the custom master page within '<%@' tag in homepage.aspx file and the link is correct. – Aizul W Mar 27 '17 at 6:28
  • sorry, I can't get you, There have scripts to detect the browser, but why we need to detect the browser, Your Issue is the custom master page is not applied for specific browser right? – Suriya Mar 27 '17 at 6:45
  • Yes. I checked my edited custom master page again just now. And now the javascript are not applying even to IE browsers. It went back to original custom master page (with no javascript edits). I didn't change a thing except pressing the green refresh button on the sharepoint 2013 designer. Is this some sort of fallback..? – Aizul W Mar 27 '17 at 6:52
0

It looks like you have not published the master page. To publish your page, go to Site Settings –> Master pages and page layouts and then find your HTML file. Hit the publish button on the ribbon.

Reference: Creating Master Page

  • Tried publishing as suggested. Does not work. – Aizul W Mar 27 '17 at 6:28
  • Sorry, comment is not clear. Can we say that it was not published earlier. Now that you have published it, it is still not working? if so, has it been approved as well. After publishing, it remains in pending state. Please confirm. – Alok Kumar Gupta Mar 27 '17 at 7:21
  • The page was published and approved and still not working. I am using highest privilege user by the way. Thanks. – Aizul W Mar 27 '17 at 7:48
  • is it possible to share screen? – Alok Kumar Gupta Mar 27 '17 at 7:50
  • Just for confirmation, is it possible that device channels are enabled on site? – Alok Kumar Gupta Mar 27 '17 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.