I have a custom application page integrated in Centeral Administration. My application pages are placed in a subfolder in Template\Admin folder. I placed my own web.config in my subfolder and added tagPrefixes in the control section.

However when I open my application page ASP.NET throws the exception that the tag SharePoint:InputFormTextBox was not recognized.

What am I doing wrong? Or it doesn't work this way? What can i do to achieve this?

Moving the add tagprefix statements in root web.config solves the problem but thats not acceptable in my case and I can't define them in individual pages either.

2 Answers 2


I can't think of any reason off the top of my head why this technique in general wouldn't work. I'm assuming you've found this is required because the parent web.config does not have any controls/tagPrefix entries, and that all tag mappings are defined in the individual .aspx pages.

One option of course, is to follow Microsoft's lead and add the tag prefix into your aspx page itself. That should work fine if you're happy to have it there.

Alternatively, what happens if you place the entry in the parent web.config (i.e. the one for the Central Admin site)?

Finally, are you sure you have the correct assembly/control reference in the tag prefix?

  • moving the entries to root web.config solves the issue but thats not an acceptable option in my case neither is putting the directives in the page directly. Commented Mar 30, 2010 at 11:59
  • 1
    Well I looked into it further and I defintely think what you're doing is possible - both 'system'web' and the child 'pages' element are not registered as 'MachineToApplication' only in machine.config, meaning it is possible to use them in web.configs not at the application root. Not sure why it's not working for you at the moment I'm afraid. Commented Mar 30, 2010 at 13:06

I had this same issue when using web user controls. The tagPrefixes in my custom webconfig file (which were in the same directory as my application pages) were not recognized.

I solved it by adding a webconfig file to the CONTROLTEMPLATES\MyCustomFolder which then allowed my user controls to see the tagprefixs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.