1

People search is not working. By this I mean when I go to my MySite profile, I put a name in the search box and it lists no results. No documents, person, or even newsfeed posts I have with their name in it. When I do the search from my portal main page, I get documents, but no people.

I have tried every troubleshooting blog post and every TechNet article I can find. I have added the sps3s:// to the synchronization, made sure user profiles are crawled, made sure the service accounts have the right permissions in the search administration, you name it, I've tried it.

The one issue that came up during my extensive troubleshooting is listing profiles. Profiles are technically listed MILDOMAIN/User.Name. When I try to list user profiles, all instructions list to putting in the domain, except when I do that, no profiles come up. However, if I put MILDOMAIN in the Manage User Profiles 'Find Profiles' box, it lists them all - in their formal configuration of MILDOMAIN/User.Name.

Any obscure reason my people search on MySites search is not working? Does it have to do with the way it is pulling in the profiles from AD?

2

The crawl configuration is straight forward, but the User Profile Service has to be set up correctly. You indicate that there is "trouble listing profiles". What exactly do you mean? In the UPS you should be able to show all your user profiles. The domain name should match your domain configuration. You should be able to browse user profiles on your My Site host by clicking the profile link. You should have no certificate errors. If all that is working then configure search as follows.

  1. Ensure that the User Profile Service and Search Service are in the Service Connections for the web applications where you are performing the search. (This is done by default, but in case it's messed up I include it here.
  2. Configure a Content Source. Add the URL for any SharePoint Web Application, usually you will reference your My Site Host, but you don't need to. If you are using SSL use the sps3s://url otherwise use sps3://url.
  3. Configure Security on the User Profile Service application. In the Service Application page choose the User Profile Service and click Administrators in the ribbon. Add the Search Crawl account and grant "Retrieve People Data for Search Crawlers".
  4. Return to the Search Service Application and start a full crawl on the Content Source containing you sps3 content source.

Once the crawl completes, check the crawl logs for the User Profile Addresses and ensure there are no errors. Test the search on the People tab in the search center.

  • I've done steps 1-4 multiple times, which means the problem lies in that first paragraph. Let me expand on the listing profiles issue. When I go to User Profiled >Manage User Profiles I should be able to put mysiteurl into the box and it should list all the profiles. Except when I do it, I get no results. Then I was thinking about how the profiles are listed in AD (the MILDOMAIN/User.Name) and I wondered if I just put MILDOMAIN into that box if it would list the profiles. It did. So it's not reading from the url, it's reading from Active Directory, maybe? Does that make sense? – Ellen Mar 23 '17 at 16:36
  • No, in the search box you should enter a domain or user name and find a profile not the MySite URL. The search crawler has to have access to a web application and then it uses the SharePoint API to pull user profiles. Another troubleshooting approach is to put the user profile start address in it's own content source so you can view the log for just the content source. What happens when you browse to the My Site Host? Do you see your user profile? – Matthew McDermott Mar 23 '17 at 20:39
  • I do see my profile. If I put in my last name in the box, it does come up. It displays as MILDOMAIN\Ellen.Harville. It's pulling in the information, just not searching it somehow. – Ellen Mar 28 '17 at 17:56
  • What are you seeing in the crawl log for the People Content Source? – Matthew McDermott Mar 29 '17 at 11:25
  • The first crawl brought in 423 Successes, and from there it has been incremental. So it's pulling the stuff in - but getting lost from there. – Ellen Mar 29 '17 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.