Workflow shows steps on web but when I try opening on Sharepoint Designer 2013 it is blank ! I have tried opening in a different machine with a different user and it opens correctly with all steps as it should open. The problem is on my user or computer.

I am already site collection administrator.

O.S: Windows 10 / Sharepoint online(Office 365) / Sharepoint designer 2013

6 Answers 6


Try clearing your SharePoint Designer 2013 Cache

  1. Navigate to the "File" menu then select "Options" -> "General" -> "Application Options".

  2. On the “General” tab, under the “General” heading, uncheck “Cache site data across SharePoint Designer sessions”.

If problem still exists, try reinstalling SharePoint Designer 2013.

  • I tried with both 'uncheck of cache...' and 'reinstalling designer' but still, the issue persists, can you recommend anything else?
    – Kb15
    Commented May 4, 2018 at 7:33
  • Unfortunately those were the only two solutions which i have tried and they worked. Commented May 15, 2018 at 6:26

If someone still face this problem, here is the solution.

Just install this MS Fix and restart SPD.


Good luck


Service Pack 1 worked for me as well - here's the 64-bit version: https://www.microsoft.com/en-us/download/details.aspx?id=42009

  • This worked perfectly for me 💕 Not sure why the service pack isn't included by default when downloading a fresh install of SPDesigner?
    – vanblart
    Commented Aug 4, 2020 at 12:27

I've seen the same thing happen on Windows 10. It does open SharePoint 2010 workflows probably, only the SP2013 workflows were shown as blank.

The following scenario worked for me: - Fresh W10 client machine (created it in Azure) - Fresh install of SharePoint Designer 2013 64 bit - Install Service Pack 1 for that 64 bit version of SharePoint Designer

Now try to open one of your (SP2013) workflows. The first time I get the error "Failed to load this workflow. To correct this problem, restart SharePoint Designer." Completely close SharePoint Designer and restart it (I didn't have to reboot the machine). Now the workflow opened without any problems.


You need to clear SharePoint Designer 2013 cache. To clear the cache you need to execute the following command from the command line as administrator on your PC and reopen SharePoint Designer:

rmdir "%LOCALAPPDATA%\Microsoft\WebsiteCache\" /s /q
rmdir "%APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache\" /s /q

Or you can download and execute the bat file.

After clearing the cache and running SharePoint Designer you may need to close and open SharePoint Designer one more time, then the error should disappear.

I also recommend installing recent updates for SharePoint Designer 2013. This will help to avoid annoying error when configuring workflows.

Note: for OnPremises version only. If you use SharePoint Designer on the same server where has installed Workflow Manager and see the message Server-side activities have been updated, please check the link.

Note: as I discovered I should mention that I affiliated with Plumsail in case if I post any links to our site.

  • FYI - it's required on all Stack Exchange sites to explicitly disclose affiliation to any links or products you give in answers. You haven't done that here with your links to plumsail.
    – TylerH
    Commented Jul 18, 2019 at 16:02
  • @TylerH I'm affiliated with Plumsail, but the question is general about SharePoint Designer. I'm not promote anything in the answer.
    – Roman
    Commented Jul 19, 2019 at 10:01
  • That the subject of the question be related to your answer is a requirement to avoid spam, but not the only requirement. See sharepoint.stackexchange.com/help/promotion - specifically, "Post good, relevant answers, and if some (but not all) happen to be about your product or website, that’s okay. However, you must disclose your affiliation in your answers." (Bold emphasis mine). Readers need to know of your affiliation (just like in any publishing scenario) to fully understand the context and value.
    – TylerH
    Commented Jul 19, 2019 at 10:07
  • 1
    @TylerH OK, no problem I edited the answer and added an additional note.
    – Roman
    Commented Jul 19, 2019 at 10:10

I have encountered this issue before.

What fixed it for me was installing the Service-Pack 1 for your version of SharePoint Designer.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.