2

i have created few splist columns in my publishing site collection and went for full crawl in my custom search service application.created a new content source. Now I wanna configure the managed properties / crawled properties such that, i will be using this in my search center's results.aspx page's left side as Refiners.

But the newly created list columns [ NOT SITE COLUMNS ] names were not appearing in the search schema / managed properties. What may be the reason for these columns disappearance? i have added few items int this new splist and done full crawl multiple times.

Also restarted the sp search service, sp timer service, and sp admin service. But all these actions are in vain . I need to get this working by seeing the mycolumn1owstxt kind of managed property.

2

You indicate you are expecting to see mycolumn1owstext. That is an Automatic Managed property. They only appear when you use Site Columns.

You should see the Crawled Property ows_mycolumn1 following a full crawl. Then you can manually create a Managed Property of any name you like.

  • i have used a doc lib column and not site column. so i thought the managed property column generated after full crawl will be having this mycolumn1owstext format. but even in the cralwed property or managed property i am unable to see the column with ows_mycolumn1. amy problem with the search serv appln ? i did a index reset and performed a full crawl again, but that also failed! – SaMolPP Mar 21 '17 at 14:00
  • i have tested again with a new SPLIsT, with newly created 2 columnsand added some value and performed full crawl in my srch serv appln. but the crawled properties are NOT getting generated. At the same time, when i created a new document library and created 3 columns and uploaded a few documents into the doc lib with filled in metadata, and performed the full crawl , the doclib columns are appearing in the crawled properties, starting with ows_mycolumn1 . so there must be some problem with SPLIST thats not getting crawled by SP search engine. is there any resolution for this? – SaMolPP Mar 21 '17 at 14:40
  • Is the list in the same web as the doc library? Are you certain that the list is crawlable? Check the Crawl Logs, the URL for the list should be there. If not you need to troubleshoot the crawl. – Matthew McDermott Mar 21 '17 at 14:58
  • Yes, I have created the doc lib & splist in the same web its in my root web. I didn't check the crawl logs yet! – SaMolPP Mar 21 '17 at 15:00
  • how to make the LIST IS CRAWLABLE? In the splist settings, i have ,made it as "YES" for the search settings of the lists's advanced settings --> allow items from this list to appear in search results Will there be any time delay for generating index / search contents or creating managed properties in a sp farm? will it take many hours or days to update the crawl db / and fetch data from crawl and populate the results in the search serv appln page ? – SaMolPP Mar 22 '17 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.