I have created a RSSFeed Webpart from Scratch its working fine on https://savan.sharepoint.com/sites/365AppzDev/_layouts/15/workbench.aspx" but when i deployed its sppkg file to appcatalog and added it to webpart page its giving me the following error. How to reslove it?

enter image description here

3 Answers 3


Following are the steps that you can try to get it working

  1. Upload the files found in the "webpartfolder\temp\deploy" to a sharepoint document library

  2. Update the cdnBasePath property (found in the file write-manifests.json) with the path to library where you have uploaded your files. This write-manifests.json file is located in the config folder

  3. Rebundle your webpart and upload the new package to the app catalogue


The resource files should be deployed in cdn or SharePoint library. The below link will give you steps to deploy in CDN.https://www.youtube.com/watch?v=FDGatKnjNeM

To use the SharePoint for your resource files you can follow below steps.

  1. Update the SharePoint library path in the <>/config/write-manifest.json -> cdnBasePath
  2. Run the "gulp bundle --ship" command, It will generate new resource files under "<>/temp/deploy" folder. Copy to SharePoint library path you specified.
  3. Run "gulp Package-solution" to get new .sppkg file. Deploy the new file.
  4. Follow steps to add to page. It should work.

Thanks, Venkat Konjeti


The .sppkg does not contain any js, css, images etc. These need to be deployed to a cdn (or similar ).

Source: https://dev.office.com/sharepoint/docs/spfx/web-parts/get-started/deploy-web-part-to-cdn

You can enable a CDN on your tenant, if it is provisioned.

Source: https://dev.office.com/blogs/office-365-public-cdn-developer-preview-release

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.