3

I'm attempting to troubleshoot an odd issue, so hopefully someone here can point me in the right direction. I've got a web part page with two dataview web parts on it. Both DVWPs use the same list as a data source - one shows a summary and the other shows details. It works fine for me, but when the intended users load the page, the top web part (the summary) shows the generic "Unable to display this web part" error. Here's what I've tried so far:

  • Recreated the DVWP from scratch, then pasted existing XSL snippets into it. Same error.
  • Had the other site collection admin load the page, DVWP displays normally.
  • Had other users (non-admins) try the page. Same error.
  • Had the users clear their browser cache. Same error.
  • Went down to one user's desk and logged into the site as myself. Same error.
  • Changed his security zone settings to LOW, restarted browser. Same error.
  • Loaded page in Chrome instead of IE11. Same error.
  • Checked the server logs for the given correlation ID, but it doesn't appear in logs or events.
  • Created a test page with ONLY the offending DVWP in it. Same error.
  • Removed all CSS and formatting from test page so it was only raw list data. Same error.
  • Turned off versioning and required check-out for the library so that there's only one possible version of each page. Same error.
  • Just for grins, checked thresholds for web app & confirmed that user and admin thresholds for list views, queries, etc. all match.

At this point, I'm kind of stumped. Logging in as myself would seem to eliminate any issues with permissions, list-view thresholds, etc. The only time it displays correctly is on my own machine, on the server, or on the other site admin's machine. But at the same time, I got the error when logged in on the user's machine, so it's not account-specific.

It seems that it has to be something machine or browser-specific, but getting the error in both Chrome and Internet Explorer, or on different user machines, would argue against that.

Has anyone seen an issue like this before, or know how to continue troubleshooting it?

SharePoint 2013 Enterprise, 5-server farm, Windows 7 machines with IE11

  • Anything in the ULS log? – mannaggia Mar 11 '17 at 19:33
0

Removing the web part from the page completely, then recreating it from scratch seems to have resolved the issue. This was actually the second time I did that, so no idea why the first time didn't work. I suspect that possibly there was some bad XSL, a typo or something that maybe got copied/pasted back into it after that first time (as I did copy some chunks of code from an older version rather than re-type it all). If that's the case, though, I have no idea why it would show for admins, but not users.

Regardless, the solution seems to have been recreating the DVWP from scratch, without re-using any of the previous XSL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.