1

I'm trying to select the following OOTB managed properties in a search for discussion threads:

  • DescendantRatingsCountOWSINTG
  • DiscussionLastUpdatedOWSDATE
  • LastReplyByOWSUSER

My query looks like this: https://sharepoint/_api/search/query?querytext='* ContentTypeID:0x012002*'&trimduplicates=false&selectproperties='Title,DescendantRatingsCountOWSINTG,DiscussionLastUpdatedOWSDATE,LastReplyByOWSUSER'

However the three properties are never returned in the result set. As an example I looked at the LastReplyByUserOWSUSER managed property which is mapped at the ows_q_USER_LastReply crawled property by default. I added the ows_LastReplyBy crawled property because maybe related to that. After a full crawl same results. All three properties are set as retrievable.

What is up with these properties? Why can't I select them and view them in the search results?

Note: On another SharePoint farm the same query works flawlessly, so I'm missing something. The result source is set to continous crawl, I ran the full crawl manually though.

  • Are the marked as "Retrieavable" in the search schema? – Robert Lindgren Mar 8 '17 at 9:10
  • All three properties are set as retrievable. Also the search works, Log shows no particular errors. – Dennis G Mar 8 '17 at 9:59
  • Ok, this doesn't seem related to these particular mm-columns. I added a TestProp mapped to crawled property Title and it is also not returned when using it in selectproperties. This is weird - why are only certain columns returned? I also tried bypassresulttypes=true – Dennis G Mar 8 '17 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.