2

I have created a 2nd managed metadata service and when I open the connection i am displayed the message below.

There is already a main metadata service running. This is a private one to be setup.

In the screen shot below, when I select "this service application is the default storage location for keywords" a message appears.

If i continue to proceed with the first instance of the managed metadata service be disabled?

enter image description here

2
  • Do u want both service application with single web application?
    – Waqas Sarwar MVP
    Mar 7, 2017 at 4:32
  • no both service application MMS 1 & MMS2 both sit on separate web applications Mar 7, 2017 at 6:03

1 Answer 1

2

If you click OK in that screen, the first MMS, where you currently have your term groups, terms, enterprise keywords and tags, won't be the default MMS. That means that all new entries will end up in your new MMS and at the same time already configured terms will stay in the old, no longer default, MMS.

This ain't a recommended procedure, and you should avoid implementing two MMS on one Web App. Otherwise you stand the risk of losing control of which terms, enterprise keywords and tags go where.

5
  • Thanks for your response. Is there another way to make the enterprise keywords unique in the 2nd managed metadata service? As they are not unique and duplicated. Mar 7, 2017 at 6:05
  • In each web application having their own MMS, yes, but not in a farm wide search center.
    – Benny Skogberg
    Mar 7, 2017 at 6:30
  • Well, i did try this when i created the 2nd MMS and it populated with the keywords from the 1st MMS. Are the enterprise keywords are shared through the farm? Note the 2nd MMS is sitting on a separate web applications. The requirements are the enterprise keywords don't populate from the 1st MMS Mar 7, 2017 at 7:19
  • @DanielleMareeSutton But did you add this to the default proxy group at first? You see this setting in the "service connection" ribbon button if you select the web app in central administration...
    – Benny Skogberg
    Mar 7, 2017 at 7:32
  • Hi Benny, as I had created a 2nd Web Application for this site collection, it is set to a custom connection selecting the 2nd MMS Service Connection. Mar 7, 2017 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.