I've been having trouble getting AD groups to show up for use in Audience rules, and a search online shows a lot of other people do, with very few sharing what is required.

Can anyone add anything to the following steps that are required to get this working?

  1. Create a Global Security Group
    • Group must be under an OU that is captured by the User Profile Import Connection search base/filter - Sharepoint 2007 seems to find groups even outside the scope specfied. That is a bit annoying for My Site profiles, as you can't hide groups with email addresses, but here it makes things a little less complicated.
    • Group does not need to be mail enabled
    • Exchange enabled groups do not need to be visible to address lists
    • Distribution Groups will not work
  2. Add at least one user to the group
    • Empty groups are not picked up
  3. Run a full profile import to pick up the group from AD
    • An incremental import is required to pick up changes to group membership, but won't get new groups
  4. Wait for 10 minutes - it can take a while before the import process is complete, despite SharePoint saying it is Idle.
  5. Run an Audience compilation to update the membership of your audience - this seems pretty instant, but it is hard to know when the above process are complete.

This doesn't quite seem complicated enough to me. I am sure there are some more gotchas in there, just to keep us on our toes!

1 Answer 1


I love how "This doesn't quite seem complicated enough to me." is the typical response from most SharePoint folks when presented with a 5 step process to get some basic out of the box thing to work. I'm constantly astonished by the sheer amount of unnecessary complexity in this product. Anyway...

Not that this will be that helpful but; I ran into a similar situation. I was unable to see AD security groups when we tried to create audiences. We found the issue to be under what you define as step one. In my case it was based on the initial selection for the import connection. We didn't have the OU which contained the group selected. Once this was changed, we did a full import and it worked. To be honest, the tree UI for the profile import configuration is not the best and it seemed our issue was more related to that not really being set to what we though it was.

Once we worked out the above the values immediately showed up.

  • That was a joke. This is one of the things that makes me hate ever having anything to do with SharePoint! I just did some testing with OUs outside the scope in step 1 - and it found them! Curiouser and curiouser.
    – dunxd
    Oct 7, 2011 at 16:45
  • Typical. I don't know how many times just trying the same thing over a few times with the same settings actually fixes problems in SharePoint.
    – Daniel S
    Oct 7, 2011 at 20:33
  • And I totally read you on the whole hate working with the product. When it works it is great, when it doesn't its not really a rewarding experience trying to fix.
    – Daniel S
    Oct 7, 2011 at 20:34
  • thats why there would be a website soon called loveandhatesharepoint.com :).This happens with all products guys and that why stackexchange is busy
    – naijacoder
    Oct 8, 2011 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.