In a hosted WSS 3.0 environment I have a standard document library with some extra columns. For some reason I cannot change the value in a choice column (called: "Status"). The value always is reset to the old value. It neither work via the edit.aspx nor the datasheet view.

I made a very short screencast to show what I mean: Screencast
EDIT: A second screencast shows the error in Edit.aspx: Screencast no. 2

Here are some more details about the error:

-The error occurs for some documents only
-The error occurs just for that specific column
-The error is user and machine independent

Here are some more details about the document library:

-No content types are beeing used/allowed
-No version is active
-Content approval is deactived
-Check out for editing is not enforced
-No documents are checked out
-The users where the errors were reproduced are site collection admin

How would you start troubleshooting?
The logs don't give my anything.

  • 1
    Reasons I can think of: Is there a workflow attached that is updating fields? Is there a event receiver? Are there required column left empty preventing a save? Is it only .doc-files? or also with some .pdf files? Is the document opened by an other user in Word? (may lock it)
    – Dribbel
    Oct 7, 2011 at 15:05
  • Thanks for you input! The environment is an hosted one, so there is absolutly NO custom development in the farm. I double checked that there is no workflow attached. The problem occures for all type of documents not only .doc files! If there were required columns left empty it would explain the behavoir in datasheet view but not in the edit.aspx form, would it?
    – AlexPoint
    Oct 7, 2011 at 20:18
  • Does this only happen in datasheet view or also when editing via the list item edit form? Oct 8, 2011 at 15:54
  • 1
    That is crazy. The only thing I can think of is the "required fields" issue. The one time I saw something like this the "Title" field was missing from datasheet view but I agree that you should get an error message when using EditForm.
    – Kit Menke
    Oct 11, 2011 at 15:35
  • 1
    Is it browser specific? Did you try in more than one browsers?
    – Ashish
    Oct 13, 2011 at 6:56

5 Answers 5


This looks to be a compatibility issue with .docx documents being used in older versions of SharePoint (ex. 2007).



It is just for the status column? Maybe I'm completely wrong, because your screencasts are from 2007, but I saw this behaviour once, after migration from MOSS 2007 to SP 2010 and it was problem with rights.

Some documents was checked out or modified by "System account" (non existing users in the new farm or disabled in AD) and even logged with farm admin account, I was unable to changed them in datasheet or edit form or so. I must use (intranet) web app. account, do some changes and it's somehow unlock file for all other users including my farm account (and yes, in "modified by" user was "system" again).

  • Yes, that would be a possible answer. But as you said this is a WSS 3.0 and it is not migrated. The documents aren't checked out and are "modified by" my account (Site collection admin). Thanks anyway!
    – AlexPoint
    Oct 13, 2011 at 12:58
  • 1
    I thought so. So one more thing (just to be sure), the option "allow multiple values" is checked for this column? This small harmless check box cause a lot of problems in enhanced views in our company on old portal pages (grouped, counted, lookuped an so on). Especially when we saved document with value, which was later changed on source list or library for another one or was deleted at all. If you add new lookup column with same values but with different name and set wanted value, it stays?
    – Molik
    Oct 13, 2011 at 14:53
  • Great input. As you can see in the second screencast the choises are Radio buttons so you cannot have multiple value. Nevertheless, I will keep that in mind for the future.
    – AlexPoint
    Oct 14, 2011 at 6:29
  • I'm sorry, second screencast won't work for me :( I can see only first screen and frozen mark at the beginning of progress bar, so would be better leave this issue to others. I'm just curious what happen.
    – Molik
    Oct 14, 2011 at 7:12

In your second screen-cast, the choices are shown as radio buttons. If the choices are look-up values, they should render as drop-down list. If I remember it correct, SharePoint does not provide option of radio buttons for look up column. Are you sure it is look-up column? Please confirm from the list settings page.

By the way, It seems the selected values are not submitted which may be caused by the ViewState turned Off

  • You are totally right, it is a choise column, no lookup column. Thank you for your input, I will update the question.
    – AlexPoint
    Oct 17, 2011 at 6:43

The problem appears to lie in the fact that this is a choice column and its name is "Status." Change the name of the column, and the problem goes away.


Today I encountered the very same issue in SharePoint 2013 on-premises. The problem occurred in an item list (so it's not specific to document lists, as implied by the original question). Just like the original poster, the problem occurred for me across multiple browsers. But for me there was the additional perplexity that the problem seemed to be specific to me: three others in my group were able to change the value of the Status field without issue.

Just like the OP, I didn't see any error information, whether in the browser, server Event Viewers, or ULS logs. In addition, I used Fiddler to check the requests, and they looked fine: the requests to ProcessQuery included my chosen value in both the request and response payloads.

Once I found this StackExchange question, I too tried performing the edits within a datasheet view, and got the same behavior as the OP. Given that all the behavior was the same and we were both encountering it on a custom field called "Status," the field itself stood out as the problem.


I faced the similar issue with one of the document library columns. Some PPTX files were having the problem. We had changed the choice values of the custom choice column 'section'. When tried to edit the properties of the ppt documents, and assigning the new value from the choice column, the value always reverted to the old one.( which was not in the column anymore).

Solution is

  • download the file
  • Save the file as 2003 ppt template
  • upload it again with the appropriate value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.