I have sea of logs from this file in console. Little bit annoying to find my own console.logs in it, and also console lags a bit. How can I disable it? Maybe in SharePoint online settings?


You can't disable it with configuration

Things you can do:

  • Use filter 'myapp.js' in console to only show log statements coming from myapp.js

  • (Chrome) enhance your logging to display colors
    console.log('%c MyApp:' , 'background:green;color:white' , mydata );

  • (coding, difficult) Monkey Patch sp.RequestExecutors.js, overwrite/disable logging code

  • ...

  • Monkey patching sp.RequestExecutor.js might not be enough because sometimes the code runs partially in an iframe where security settings prevent tinkering with the code – Marcus Krahl Oct 12 '17 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.