1

I'm following the few examples I could find about implementing a spfx webpart with angular2. I get this error when deploying to the site workbench (../layouts/workbench.aspx)

[SPWebPartErrorCode.ScriptLoadError]:: Unable to load web part WebPart.WpAngularTest2WebPart.b233d030-a920-4c7c-b68f-6ee216958ae1,Error: ***Failed to load component "3c175eae-302b-4af5-b943-48227ffd91b7" (WpAngularTest2WebPart). Original error: ***Failed to load component dependency "@microsoft/sp-webpart-base" from component "3c175eae-302b-4af5-b943-48227ffd91b7" (WpAngularTest2WebPart). script resources due to: {1}. CALLSTACK:: Error at t [as constructor] (/files/sp-client-prod_2017-02-13.012/sp-loader_en-us_e10f93aa29d8eff41e6d241bc285557f.js:57:21452) at new t (/files/sp-client-prod_2017-02-13.012/sp-webpart-base_en-us_fbedfc4c29d013d7a0d32e62a349ff62.js:47:21988) at Function.t.create (/files/sp-client-prod_2017-02-13.012/sp-webpart-base_en-us_fbedfc4c29d013d7a0d32e62a349ff62.js:47:22429) at /files/sp-client-prod_2017-02-13.012/sp-webpart-base_en-us_fbedfc4c29d013d7a0d32e62a349ff62.js:48:627

thanks

1

The SPFx GA has not reached your tenant yet.

At your end, the files are available dated 13th Feb files/sp-client-prod_2017-02-13.012. The GA file version is files/sp-client-prod_2017-02-17.019

Once this is updated, the webpart will start working. Wait till tomorrow according to below link -

SPFx failed to load components

  • Thanks, using the browser developer dashboard i can see the files from the server are dated to 2017_-02-13 so i dont thinks that the problem. – Lior Gal Feb 27 '17 at 14:24
  • 1
    The files need to be 2017-02-17.019. 17th Feb. This will get updated by tomorrow, the 13th Feb version is older one, hence not working. – Gautam Sheth Feb 27 '17 at 14:35
  • Hi, The version did updated to 2017-02-17.019. 17th Feb on my site but now i get the same error for this date: spoprod-a.akamaihd.net/files/sp-client-prod_2017-02-17.019/…) at new ... – Lior Gal Feb 28 '17 at 11:31
  • @LiorGal - thats strange , can you edit the question with the new error message ? Also, can you create a simple new hello world webpart and check ? – Gautam Sheth Feb 28 '17 at 11:53
  • hi, i added the new error. any ideas ? – Lior Gal Feb 28 '17 at 13:36
0

The New error today is: SPWebPartErrorCode.ScriptLoadError]:: Unable to load web part WebPart.WpAngularTest2WebPart.g_eacdc229_6eb0_472c_ba02_c5b206237fdf,Error: ***Failed to load component "3c175eae-302b-4af5-b943-48227ffd91b7" (WpAngularTest2WebPart). Original error: ***Failed to load path dependency "wpAngularTest2Strings" from component "3c175eae-302b-4af5-b943-48227ffd91b7" (WpAngularTest2WebPart). script resources due to: {1}. CALLSTACK:: Error at t [as constructor] (https://spoprod-a.akamaihd.net/files/sp-client-prod_2017-02-17.019/sp-loader_en-us_c7a5ee2faf8f15c3c9ab1ecc5e7db21d.js:57:21740) at new t (spoprod-a.akamaihd.net/files/sp-client-prod_2017-02-17.019/sp-webpart-base_en-us_f7b0b90820799ba53083111c72956e29.js:47:22746) at Function.t.create (spoprod-a.akamaihd.net/files/sp-client-prod_2017-02-17.019/sp-webpart-base_en-us_f7b0b90820799ba53083111c72956e29.js:47:23187) at https://spoprod-a.akamaihd.net/files/sp-client-prod_2017-02-17.019/sp-webpart-base_en-us_f7b0b90820799ba53083111c72956e29.js:48:6311

It ssems to be working off and on after i clear the browser cache but i cant put my fingure on the cause yet.

It seeme to be working only on chrome browser (not on ie) and i needed to re install and clean the browser cache. Many thanks to Gautam Sheth for is help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.