1

I am facing an issue in my multi server SharePoint Farm as my load balancer is pointing to only one WFE not the other WFE.


(I have checked in Load Balancer's configuration and both WFEs are mentioned in the redirection list and Load Balancer configuration is all fine.)

My SharePoint Farm is: 1 App Server + 1 Search Server + 2 WFEs (WFE1, WFE2)

I have a public DNS record http://publicurl which is the mentioned in Load Balancer as well

Load balancer has been configured with SSL i.e. HTTPS but all the servers are configured for HTTP only and load balancer itself takes care of converting HTTPS to HTTP for internal SharePoint farm servers i.e. SSL offloading is enabled at Load Balancer

Alternate Mapping is:

Public Zone URLs:

enter image description here

Internal URLs:

enter image description here

All is working fine, but now I tested my Load Balancer if its pointing to the both two WFEs or not. But to my surprise its pointing to only WFE1 I tested it by placing two different images at the same location of WFE1 and WFE2

C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\IMAGES

And in my browser I opened the following URL many many many times:

https://publicurl/_layouts/15/images/test.PNG

Every time I hit this URL only the image at WFE1 opens

Also I turned OFF my WFE1 and then the URL https://publicurl was not available anymore and was unreachable.

This all confirms that I am always hitting my WFE1

Can anyone suggest what exactly I am doing wrong

0

https://publicurl should be the A record in DNS. DNS should point to the load balancer (get the listener IP) and the load balancer should redirect to both the WFE IPs. In SharePoint central admin go to AAM and add public URL as your SharePoint site instead of default one.
SSL offloading at Load balancer is fine and load balancer will convert HTTPS into HTTP traffic and redirect to specific web app.

Don't have to bother for load balancing APP servers unless needed, SharePoint's internal application takes care of it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.