Here are the steps I am taking

  1. Updating the existing MDS to enable hub (setting URI to a specific site collection)
  2. Update the content type in the site collection to be set to publish
  3. Run the timer jobs (content hub and the subscriberjobs)

Not seeing the content type, and on the content type it has no last publish date listed.

Ideas as to why?

  • nothing in the error log
    – dbobrowski
    Commented Oct 6, 2011 at 13:29
  • It may be early, but what is MDS? Commented Oct 6, 2011 at 13:33
  • 1
    When publishing, errors do not go in the SharePoint error logs, they go to /Lists/ContentTypeSyncLog/. You can access it by Site Settings > Site Collection Admin > Content Type Publishing > Content Type publishing error log. is anything in there? Commented Oct 6, 2011 at 13:35
  • @Tim MDS = metadata service I wasn't looking in the ULS logs, I meant there was nothing in the content type sync error list.
    – dbobrowski
    Commented Oct 6, 2011 at 13:42
  • Also... on "content type publishing" the correct metadata proxy is shown
    – dbobrowski
    Commented Oct 6, 2011 at 13:44

4 Answers 4


I fixed my issue by creating a new site collection to serve as the content type hub, then changing the metadata service to point to that new site collection for the hub property


I believe my original issue was due to me not waiting for the "content type hub" timer job to complete before running the "content type subscriber" job. In addition, for anyone running into this issue, be sure you go to the site collection serving as the hub and in the site content type >> specific content type >> properties, click publish BEFORE the jobs run.

  • Thanks so much! For me these steps fixed my problems: delete old CTH, set new CTH URL for MMS, (re-)publish all Content Types in Hub, run Content Type Hub Job, check box "Refresh all published content types on next update" for Content Type Consumer Site Collection, run Content Type Subscriber Job. Commented Sep 29, 2014 at 8:42

I had the issue where some site collections would receive the content types, while others would not. This is what finally solved my problem:

  • Central Admin/Application Management/Configure Service Application Associations
  • Select the appropriate Application Proxy Group
  • Uncheck the MMS thats having issues and click OK
  • Wait a couple of minutes
  • Select the Application Proxy Group and add the MMS back
  • Either wait for the Content Type Hub job to run, or go to Central Admin/Monitoring/Review Job Definitions, select Content Type Hub, and select 'Run Now'
  • Either wait for the Content Type Subscriber job to run for your Web App, or 'Run Now'

This worked for me. I never had any errors in any logs. This was a very frustrating issue.


This is how i fixed it.

In Central Admin > Manage Service Applications > Managed Metadata Service (The Service Connection, not just the service) > Highlight and Click Properties.

At this point you have 4 check boxes.

  • This service application is the default storage location for Keywords.
  • This service application is the default storage location for column specific term sets.
  • Consumes content types from the Content Type Gallery at http://devinsider15.mccarthy.com/cthub.
  • Push-down Content Type Publishing updates from the Content Type Gallery to sub-sites and lists using the content type.

All were checked for me except one. (Consumes content types from the Content Type Gallery at http://devinsider15.mccarthy.com/cthub)

After checking that box, and re-running timer jobs, i was in business and working.

See figure 5.10 on this site (http://sharepoint-community.net/profiles/blogs/understanding-content-type-hub-cth-in-sharepoint-2013 )


I've struggling for the last day trying to get this to work. I'd done everything that was required by every guide that I had read.

I was afraid that it might be something to do with the order of the way I had put it all together. I had already started using the content types and didn't want to have to recreate them and reassign the data.

Out of curiousity, and chance, I created a new content type that used one of my desired types as its parent. After running the timer jobs, lo and behold, both types were available in the new site collection.

I was then able to "unpublish" this content type and delete it. The desired contetnt type remained put. Sweet relief.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.