0

When I click on an Office file like Word or Excel it does not open in the browser but rather shows me a dialog that asks me to open it using the corresponding office application.

I have the authentication provider for the site as claims based. Below is a photo that that shows my issue.

enter image description here

Hopefully, there is a solution for this problem.

2

Try to set the the default open behavior for the site collection or document library based on your requirements as the following.

To Set the default open behavior for site collections as the following:

  • In the SharePoint site collection, choose the Settings icon > Site Settings.
  • On the Site Settings page, under Site Collection Administration, choose Site Collection Features.
  • On the Features page, for the Open Documents in Client Applications by Default feature, choose Activate to enable the OpenInClient feature (documents will open in the client application), or Deactivate to disable the OpenInClient feature (documents will open in the browser).

To Set the default open behavior for a document library by using the document library settings page:

  • On the document library page, choose the Library tab.
  • In the Settings group, choose Library Settings.
  • On the Document Library Settings page, choose Advanced settings.
  • On the Advanced Settings page, in Opening Document in the Browser, select Open in the browser from the following options:
    • Open in the client application When a user chooses a document in this library, the document will open in the corresponding client application if it's available.
    • Open in the browser When a user chooses a document in this library, the document will open in the web browser in the web app for that document type.
    • Use the server default When a user chooses a document in this library, the document will open by using the default open behavior specified for the server running SharePoint 2013.

If the issue still exists please review the configuration of Office Web Apps as mentioned at Use Office Web Apps with SharePoint 2013. So in this case,

For more details check Set the default open behavior for browser-enabled documents (Office Web Apps when used with SharePoint 2013)

  • I do not have the Office Web Server installed, I tried to install it but it complained that it cannot be installed on the same server as SharePoint. My current enthronement is for testing only. All of my settings is as you mentioned above. – Saleh Omar Feb 21 '17 at 8:53
  • sorry for late reply, Yes You cannot install OfficeWebApps on the same server as SharePoint, in my environment I have SharePoint 2013 with the same version of office 2013 64bit that open in browser properly ? are you have the same specifications? – Mohamed El-Qassas MVP Feb 25 '17 at 12:35
0

You need an Office Web Apps (OWA) Server to be able to open Office-Documents in browser. You cannot install OfficeWebApps on the same machine as SharePoint, you need a separate server for that.

The installation-process is documented in Technet. As you are on a testing-environment, you can use HTTP instead of HTTPS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.