0

I have created a survey for this i need to send an email to a group when new response is added. can anyone help how to do this.

2

You can follow this steps to send email on survey response.

  1. You create a designer workflow to send email on Survey list.
  2. Open the Site in Designer and go to workflow section
  3. Select List workflow in that choose your survey list
  4. Designer create a workflow editor to write the actions
  5. Select the "Send an Email" action in that workflow action as shown in picture
  6. Select To in that email window, you can choose a user or a SharePoint group
  7. you can also specify CC users or groups it is optional, Subject and body of email also you can specify in that editor.
  8. Save the workflow and go to workflow settings
  9. deselect "Workflow manually started" and select "start workflow automatically when an item is created" and changed also if required.

enter image description here enter image description here enter image description here enter image description here enter image description here

  1. Click on publish work flow in top ribbon.

you can receive email when a survey is responded..

  • Thanks for your answer. I tested survey by creating new response but no email received. – sai Feb 21 '17 at 6:47
  • Are you using 2013 Workflow or SharePoint 2010 - In 2013 if there is no user exist in the site with the email id which you want to receive alert on that email should exist other wise it won't send external emails until that email should tag to any user in the sharepoint – Suresh Bolineni Feb 21 '17 at 8:18
  • I tried using both 2010 and 2013 , and i am using existing email id only but i dint receive email – sai Feb 21 '17 at 8:42
  • check the workflow history is there any issue logged there please check and post the issue here, if any issue if there is no issue SharePoint sent email successfully then you need to check the email receiver might have problem in exchange – Suresh Bolineni Feb 21 '17 at 9:47
  • Thanks for the answer i change settings in outlook now i am receiving email. – sai Feb 22 '17 at 3:42
0

This has worked from me, however I'm Site Admin so I'm not sure if this will work for those with Full Control(Owners) although it should. This is also in the SharePoint 2013 environment with a SharePoint 2010 workflow.

With Designer go into your workflow and create a Impersonation step. Move the email step into this. Also mark it to start when an Item is created. (I created a whole separate workflow for when an item is edited using the same steps). Remove the regular empty step. I've set everything back so that users can only read/edit their own items. Emails have come through fine now.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.