This is a SharePoint 2016 system. No matter in what library, clicking on "open with explorer" does nothing - no error, no action. This is a problem for all users (IE11 on win10, mostly, but also on win8.1, server 2012/2008).

Thing is, if we copy the browser address bar and paste it into file explorer, it works, so at least we have a workaround, but then again reauthenticating is required.

With a cleanly setup SharePoint test system, it does not work, either, but at least we get this:


That test system has not seen any patch yet, maybe that is why it is "failing a little less".

The usual suspects were tried:

  • 1
    We have found out that the problem can be solved by changing part of the master page to http-equiv="X-UA-Compatible" content="IE=10" (on clean installations, it is "IE=9" and on our productive machine, we had set it to IE=Edge, because with IE=9, drag and drop does not work). Still, windows explorer is asking for credentials. Why can't it reuse those of the user that is logged on? Time for a new question.
    – MTG
    Mar 8, 2017 at 15:13
  • 1
    Check this blog.devoworx.net/2015/03/23/… Aug 11, 2018 at 9:03

2 Answers 2


I have seen issues with "Open with Explorer" when "Trusted Sites" are managed by Domain Policy, and the list of trusted sites contain illegal wild-card URLs.

Check to see that all the other "Trusted Sites" are indeed legal URLs.


Open with Explorer option does not work in IE 11. I have faced this issue. The trick is, open your IE developer tool and simply change the browser mode to IE 10 and then Open with Explorer option will start working.

  • 3
    Zakir, it is solved. Further changes to the master page were required. Thanks anyway.
    – MTG
    Jun 12, 2018 at 8:49
  • 1
    Let us know what changes you had done in master page. I think most probably you would have updated the <meta http-equiv="X-UA-Compatible" content="IE=edge"> element?
    – Zakir HC
    Jun 25, 2018 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.