0

We have setup up SP 2013 and enabled auditing. The issue is when I try to run a custom report on a sub site I get the error...It does not allow me to select using browse buttons in either the "Save location" or the "Restrict the report to:" browse.

Sorry, something went wrong

Report contains no data.

I have included screenshot of what I am running. When I return to the screen after the error the "Restrict the report to" checkbox is unticked and the text field greyed out.

enter image description here

As a foot note I have also tried this directly from a custom list item (custom lists I need to get this working on). I click on Compliance details > Generate audit log report with the following errors: When I attempt to change the save location

Sorry, something went wrong Reports cannot be stored at '/Documents'. Reports can only be stored in a document library in the current site.

When I do not change the list save location

Sorry, something went wrong Report contains no data.

  • I was able to resolve the above issue by selecting a document library as location and selecting a higher Date Range. – Amay Kulkarni May 2 '17 at 13:01
1

You must be a site collection administrator, then you can do:

Site Actions

Site Settings

Modify All Site Settings

Site Collection Administration

Site collection audit settings

Cofigure Audit Settings - and check the boxes that are appropriate for your case.

This article help you to configure audit setting and view audit log reports from Site settings: https://community.spiceworks.com/how_to/126012-how-to-track-changes-on-sharepoint-server-2013

Thanks,

  • This does not solve my problem. As mentioned from the outset - auditing has been enabled. The issue still is unresolved – garvon-77 Feb 15 '17 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.