1

I've made some adjustments to the library we are using, but now users can't direct edit the items in the desktop. However, I can.

They see the following:

  • Green locks on every document
  • When they open a document its in read-only mode
  • When they try to upload a new document they are asked for administrator rights.

enter image description here

How do I fix this? So that every user is able again to edit and upload documents on the fly.

Thank you.

  • Have you found a solution for this problem? Kind regards, – Talman Mar 10 '17 at 13:20
  • 1
    Yes. Disable version control, and disable check-out. – Bas Mar 13 '17 at 8:12
0

I wanted to retain versioning, so i turned version control off, restarted the app, synced a couple of files (green padlock disappeared), enabled version control again, restarted the app, now working fine - no green padlock and files not read only.

  • 1
    Should have mentioned that check-out was always disabled also. – Jim Aug 14 '17 at 19:41
0

I thought I'd just add my 2c here for anyone else. I had this issue and dug through my document library, removing all kinds of custom content types and columns etc. to no avail. What fixed it for me was:

  1. Open the document library in Sharepoint Editor

  2. Click Edit List columns

Edit List Columns

  1. Delete all custom columns

I added a bunch of custom columns thinking they might be useful... but they were never populated or used. Offline syncing is so much more useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.