3

I am Unable to connect to SharePoint Online site collection via Designer 2013.

I even tried to update with the service pack-1 and recent updates but none of them has helped. We have ADFS configured in our environment but i was able to connect to any site collection earlier.

As an additional note,

  • I am unable to pass the credentials directly through powershell. it works only when you enter them via authentication window.

  • I am unable to connect via third party tools such as metalogix as well

Also, I am the SharePoint Admin for my tenant.

Error Message-1:

Path does not exist. Check the path and try again.

Error Message-2:

Continuously getting authentication prompt to enter the credentials.

Tried all the below:

  1. Able to access on-premise SharePoint 2013 sites

  2. Verified access on non domain computers and as well as on the computer on which it is working for a different admin user.

  3. Verified all the SharePoint related permissions and added design permissions also

  4. Uninstalled and reinstalled the designer couple of times.

  5. Cleared the designer cache and even tried testing on a new user profile

  6. Added the site & domain in trusted sites of the browser.

  • Can you upload or edit SharePoint Online documents from say, Word or Excel? – Mike Feb 17 '17 at 3:18
  • Do you have multi factor authentication enabled? Are you using app passwords in O365? – obartholdson Feb 23 '17 at 12:12
  • MFA is not enabled and no app passwords. its only ADFS and single sign on enabled environment. – kesava Feb 23 '17 at 19:50
2

Couple things to try from here:

  1. Add your SharePoint site into trusted sites of your browser.

  2. Manually install the ADFS token signing certificate on the client computer(in case it is a self-signed certificate).

  3. Try to clear your SharePoint Designer cache (from here):

    • Close SPD if it is open

    • Open My Computer

    • a.Click the address bar

    • Paste in: %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache

    • Delete everything within this location

    • Click the address bar

    • Paste in: %APPDATA%\Microsoft\Web Server Extensions\Cache

    • Delete everything in this location

  • I have tried them already. Updated the question. – kesava Feb 17 '17 at 21:40
  • do they work correctly on another computer? with your login? – Mike Feb 17 '17 at 22:11
  • no its not working – kesava Feb 17 '17 at 22:15
  • how about with another user? – Mike Feb 17 '17 at 22:16
  • same behavior. not working. – kesava Feb 17 '17 at 22:17
1

For SharePoint Designer, the following steps worked for me:

  • Install harePoint 2013 Designer
  • Install SharePoint 2013 Designer SP1
  • Ensure SharePoint 2013 Designer is enabled in SharePoint admin
  • Ensure custom scripts are allowed in O365 SharePoint Admin Center
  • Add SharePoint site to IE Trusted Sites on machine used for editing
0

The resolution for this problem would be setting the “LegacyAuthProtocolsEnabled” property to “true” in case if it is false.

Because the value with false prevents Office clients using non-modern authentication protocols from accessing SharePoint Online resources.

MSFT agreed it as a bug on their side so we need to update it via powershell. This will enable the

Here is the reference TechNet article for the same https://technet.microsoft.com/en-us/library/fp161390.aspx

enter image description here

0

On SPD go to File Account Click on Switch Account Login with office 365 account

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.