1

I changed the password of the administrator account and then when I log on with the administrator account on my sharepoint sp-site I can't do anything, so i try to get all owner of all sp-site

enter image description here

As you can see in the picture, my site "empi-serv:82" has no owner.

Is there a way to fix this?

1
  • You said "still the same problem" after adding the Owner in Central Administration. Did you get an error there, or the change just did not stick? Does the user show up in Central Administration, but not in PowerShell? Feb 13 '17 at 17:48
1

It is really odd but can be happen, if site is recovered or move from other location. In that case run the IIS reset on all servers in farm.

Or you may need to refresh the sites in the COnfiguration also fix the issue.In below script the replace the Databasename with the actual DB name under which your site collection is.

$db = Get-SPDatabase | where {$_.Name -eq "DatabaseName"}
$db.RefreshSitesInConfigurationDatabase()

Or use the below script to set the primary site collection admin.

Set-SpSite http://sharepoint.crescent.com -owneralias "domain\user"

Read this: http://www.sharepointdiary.com/2013/01/change-site-collection-primary-secondary-administrators.html

5
  • still the same problem Feb 13 '17 at 16:28
  • What steps you followed?
    – Waqas Sarwar MVP
    Feb 13 '17 at 16:28
  • refresh the configuration BD then set the owner Feb 13 '17 at 16:35
  • Are you able to browse the site collection? also go the central admin > Application management> view all site collection and search for your site and see if you can get details over there
    – Waqas Sarwar MVP
    Feb 13 '17 at 16:36
  • yes i can view details about site collection and it says that that user is the owner Feb 14 '17 at 7:52
0

Try to log in to central administration, find that site collection and change/add primary site collection administrator.

This article has all the details on how to do it.

1
0

you can try adding a new user

New-SPUser -UserAlias 'EMPIDOM\Administrator' -DisplayName 'Administrator' -Web 'http://empi-serv:82' -SiteCOllectionAdmin

Please use the appropriate alias and display name. So this new user is now site collection admin you should be able to get it in PS

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.