1

SharePoint 2013 Pre-requisites installation failed with error "Windows Server AppFabric: installation error"

After checking event logs, below error is logged.

"AppFabric installation failed because installer MSI returned with error code : 1605"

I have tried to install it manually using below command but it failed with same error.

prerequisiteinstaller.exe /AppFabric:prerequisiteinstallerfiles\AppFabric1.1-RTM-KB2671763-x64-ENU.exe

Also checked the environment variable value and it is as below.

C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\PowerShell\Modules\;c:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules

Even as suggested in few blogs checked for the groups AS_Observers and AS_Administrators and these groups does not exist.

Can someone suggest any other solution???

  • I had the same problem as OP. Spent days trying to find a fix. I tried uninstalling and reinstalling AppFabric via command line. It did not work for me. I then tried the PSModulePath solution that's been suggested everywhere. Did not work for me. At one point I realised I couldn't even install AppFabric at all (error code 1603) so I couldn't uninstall it either which is why a lot of the fixes weren't working. I must have stuffed something up from one of the fixes I found online. I don't know if that was your issue, but ultimately I started the installation from scratch again. It was faster. I – HomerSimpson1 Feb 4 at 23:35
1

Before running AppFabric1.1-RTM-KB2671763-x64-ENU.exe, you should make sure that you have installed WindowsServerAppFabricSetup_x64.exe as the following:

  • Open CMD as administrator,

  • Navigate to the folder that contains WindowsServerAppFabricSetup_x64.exe (In my example I consider it in C:\ drive)

  • Run the following command

.\WindowsServerAppFabricSetup_x64.exe /i /gac

  • Now Click on AppFabric1.1-RTM-KB2671763-x64-ENU.exe to install the AppFabric patch.
  • Reboot the server > Run SharePoint Installation again where the message error should not be listed again.

For more details check Windows Server AppFabric is not correctly configured During installing SharePoint Server 2013

| improve this answer | |
  • I tried the steps suggested by you but still same error(AppFabric installation failed because installer MSI returned with error code : 1605) while running SharePoint Installation after reboot. – Saurabh Jawalekar Feb 14 '17 at 5:14
  • 1
    run the command with the following parameter .\WindowsServerAppFabricSetup_x64.exe /i CacheClient,CachingService,CacheAdmin /gac then check result also please tell me are you run prerequisite as offline mode or online mode – Mohamed El-Qassas MVP Feb 14 '17 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.