4

Anyone else getting the above error? Two webparts that worked fine yesterday today are failing with:

[SPWebPartErrorCode.ScriptLoadError]:: Unable to load web part WebPart.DelmeWebPart.25d255cb-7c93-4eb6-ba2e-189e6703d0e8,Error: ***Failed to load component "6b2c929f-6fae-498c-9109-a7ebb06ae045" (DelmeWebPart). Original error: ***Failed to load component dependency "@microsoft/sp-webpart-base" from component "6b2c929f-6fae-498c-9109-a7ebb06ae045" (DelmeWebPart). script resources due to: undefined. CALLSTACK:: Error at t [as constructor] (https://spoprod-a.akamaihd.net/files/sp-client-prod_2017-01-30.032/sp-loader_en-us_2032158c7e81d8ca6cabd8d5f3651bfa.js:57:19057) at new t (https://spoprod-a.akamaihd.net/files/sp-client-prod_2017-01-30.032/sp-webpart-base_en-us_83e865c7afcaf523daf607745ec20719.js:47:22053) at Function.t.create (https://spoprod-a.akamaihd.net/files/sp-client-prod_2017-01-30.032/sp-webpart-base_en-us_83e865c7afcaf523daf607745ec20719.js:47:22502) at https://spoprod-a.akamaihd.net/files/sp-client-prod_2017-01-30.032/sp-webpart-base_en-us_83e865c7afcaf523daf607745ec20719.js:48:714

I even created a new webpart from the yeoman generator and it too fails with the same error. This is only happening in the _layouts/15/workbench.aspx though-- some webparts I had previously deployed to my site are running fine. These are all react webparts.

Any ideas?

  • I don't get the error with new webpart create with yeoman using no framework – russellg Feb 9 '17 at 20:35
  • Ok, even my old webparts are now working. I did not change anything... must be the storm! – russellg Feb 9 '17 at 20:37
4

That was our fault. Sorry about that. Rolled back the change a few hours ago.

  • its happening again after I upgraded to GA – russellg Feb 24 '17 at 22:26
  • Is there a chance that you have build using the 1.0 release, but your farm hasn't been upgraded yet? If you look at the network traffic (dev dashboard), you'll want to make sure that the files (say sp-client-base) are coming from a CDN with 2017-02-17.xxx in the path. If they say 2017-02-13.xxx, your farm hasn't been upgraded yet. – PatMill_MSFT Feb 25 '17 at 0:59
  • yes, i was in the wrong folder, was building an older version of code. it's working now – russellg Feb 25 '17 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.