0

I'v been struggling with getting to work for a bit so thought I would raise on here to see if anyone else has experienced a similar issue / can point me in the direction of any guides.

I have used the search bar to see any anyone else has posted this but have been unsuccessful.

Task:

I wish to create multiple templates(Word / Powerpoint) which I can access from a sharepoint 2010 Library. Library Tools > Documents > New Documents > Templates should appear under here.

From here I should be able to open a template. When opening a template the Document Information Panel should open which should display all the Columns that have been set up on the Site Library.

Problem:

So far I'm just trying to get two templates to work - 1 Word doc / 1 Power Point template.

I have Created the 2 site content types for each of the template. Under advanced settings I have uploaded the template I wish to use.

I have then gone back into the site Library > Library Settings > Advanced Settings > Allowed Management of content Types.

I have then added the two content types I have created with the templates inside of them.

From here I have now created all my Library Columns.

I have then gone back into the content types and added these columns to the Content Types. (Columns > Add from existing site or list > current list > Added all column names > Ok)

When looking back in the Library settings I can see that these columns are "used in" the content types.

I now go back to the Library > Library Tools > Documents > New Document and select one of the templates.

When going into the Power point template all the column names are pulled through. When saving these Power Point documents the meta data entered will then be imputed into the Library and will be visible.

When doing this the same for the word template the Information Panel is not appearing at all. > I have checked the advanced properties > Custom and it appears that the custom fields are not pulling through in word?

Please let me know if any further information is required. Or if anything needs to be explained a bit better.

Thanks Steven

0

I've had a lot of problems with Word templates. Each time I added a new column in a content type I had to upload a new Word template.

The first thing you can try is to enable the option "always show the document panel information". This option is in the list content type.

Library settings -> choose content type -> advanced configuration

Another option is to edit the template. If you can, you have to open the Word template and on the "Developer" tab click above "Document Panel" button. Save the template (in Sharepoint) and close it. You could edit the template in the list content type advanced configuration page.

If you can't do that, my last option is to create an empty template using Word and save it in the list content type. When you create a new document you'll have all quickparts for your columns. If you don't know how to do it I can help you.

  • Thanks very much, I have already tried the "always show the document panel information". Option but that did not seem to work. I will try re-uploading the template a few more times, I have done it once but that didn't seem to resolve the issue. I will try what you suggested in the last sentence and let you know if this works. Thanks – Steven Daly Feb 8 '17 at 16:18
  • For the last option, I edited the default template of the list content type called "template.dotx" and saved it on my local disk. After, I saved it in "layouts" folder and I typed the URL "mysite/_layouts/MyContentTypeTemplate.dotx" in the field "Update a new document template" for the list content type. Good luck! – Idryl Feb 8 '17 at 16:37
  • Hello Ldryl, I can confirm that "Always show the document Panel Information" check box has been ticked on the content type. I can also confirm that on the template I have ticked the "Always show Document Information Panel on document open and initial save". This has caused the DIP to show, however only shows a 'Title' field. > I went back into the Library settings, Went into my content type, removed all the custom columns and added them back in again. This still didn't get them to publish in DIP, just the "Title" field was showing. – Steven Daly Feb 9 '17 at 9:45
  • Try to upload a new empty template in the list content type – Idryl Feb 9 '17 at 9:47
  • Editing the template.dotx document did work. The only problem with this is that I will require multiple different – Steven Daly Feb 9 '17 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.