1

Just recently, with no system changes other then installing NINTEX Workflow/Forms all of our SharePoint 2013 workflows stopped working.

I removed NINTEX workflow after seeing this and I am still seeing the same behavior.

If I restart the "World Wide Web Publishing Service" on the WFE all the SharePoint 2013 Workflows work. But then it they will all stop with no errors after about 5-15 minutes. When you try to manually start the workflow and go into the workflow page you get this message "Some workflows may not be shown. We were unable to reach the workflow service." and if you try to start a 2013 workflow it will fail "Something when wrong. To try again, reload the page and then start the workflow".

All SP 2010 workflows work fine.

I have re-registered both the servers with

Register-SPWorkflowService -SPSite "https://sharepoint.domain.local/" -WorkflowHostUri "http://workflowserver.domain.local:12291/" -AllowOAuthHttp -Force

*correct ULR where used

I have also tried using https for the workflow server with port 12290 with the correct cert and its the same result.

Really not sure where to go from here. The only other thing i have noticed is when i tured debugging on in the event logs for Workflow I do see.

"Calling BeginAcceptMessageSession. There are now 50 pending accepts. The oldest pending accept started at 02/08/2017 12:55:07."

and

"An AcceptMessageSession operation completed. If the operation failed, the method that threw the exception was 'EndAcceptMessageSession'. There are 49 accepts still pending."

But that 49 number never changes....

Any help would be greatly appreciated!

  • Also Recycling the SharePoint Application Pool on the WFE will make the Workflows start working again also. – Corey M Feb 8 '17 at 13:08
0

We didn't use Nintex, but other problem description are pretty the same. And debug messages exact the same

From time to time iisreset on SharePoint server can help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.