0

I am facing a problem that the full crawl never ends. now i have never similar problem since we have deployed the live sharepoint around 3 years ago. but last week i have noticed that new contents are not being indexed. so i went to "CA">>"Search">>"Content Sources" , and i noticed that the full crawl is running since 5 days.

so i did the following:-

  1. i stop full crawl.
  2. do an index reset
  3. run the full crawl again.

now the new content will be shown in the search, but still the full crawl will never end.

so i did the following steps:-

  1. i stop the current full crawl.
  2. do an index reset.
  3. restart the timer service
  4. IIS reset.
  5. start a full crawl

but still the crawl is running for more than 10 hours .here is part of the logs:-

1) i can see this error "Transaction failed in plugin RHTG" & "Thread failed to move file for docID" inside "Crawler:Gatherer Service" as follow:

02/07/2017 22:30:55.43  mssearch.exe (0x273C)                       0x15C4  SharePoint Server Search        Crawler:Gatherer Service        dsg6    Medium      CRobotThread::Thread failed to move file for docID 5348, URL sts4://tttgvsps01/siteurl=/siteid={e30d5d1e-b7d1-4fa2-8223-5f9ad3345d56}/weburl=Customer Sites/Customers/webid={2c5b67cc-9c20-4439-8e18-fa071e5a4d0c}/listid={041ad674-a322-4a88-894d-5fff45d03b0b}/viewid={f954d4c5-b691-42ca-9339-317480e66194}, Error 0x80070020. The transaction will be retried.  [robotthrd.cxx:4833]  search\native\gather\gthrsvc\robotthrd.cxx    9df3b499-4f39-472d-b175-8c84bec1103b
02/07/2017 22:30:55.43  mssearch.exe (0x273C)                       0x15C4  SharePoint Server Search        Crawler:Gatherer Service        fus3    Medium      Transaction failed in plugin RHTG Url sts4://tttgvsps01/siteurl=/siteid={e30d5d1e-b7d1-4fa2-8223-5f9ad3345d56}/weburl=Customer Sites/Customers/webid={2c5b67cc-9c20-4439-8e18-fa071e5a4d0c}/listid={041ad674-a322-4a88-894d-5fff45d03b0b}/viewid={f954d4c5-b691-42ca-9339-317480e66194} Error 0x80040d79  [gthrtrx.cxx:950]  search\native\gather\gthrsvc\gthrtrx.cxx    
02/07/2017 22:30:55.43  mssearch.exe (0x273C)                       0x15C4  SharePoint Server Search        Crawler:Gatherer Service        fus5    High        Transaction failed in plugin RHTG Url sts4://tttgvsps01/siteurl=/siteid={e30d5d1e-b7d1-4fa2-8223-5f9ad3345d56}/weburl=Customer Sites/Customers/webid={2c5b67cc-9c20-4439-8e18-fa071e5a4d0c}/listid={041ad674-a322-4a88-894d-5fff45d03b0b}/viewid={f954d4c5-b691-42ca-9339-317480e66194} Error 0x80040d79. This will generate a retry  [gthrtrx.cxx:958]  search\native\gather\gthrsvc\gthrtrx.cxx    

2) also i found this errors related to User Profile service (baring in mind that i do not have mysite enabled!):-

02/07/2017 22:23:09.72  w3wp.exe (0x4368)                           0x2600  SharePoint Portal Server        User Profiles                   cm6y    High        User Profile Application Proxy failed to retrieve partitions from User Profile Application: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have bdeb6d58-f138-4070-84af-f95d1d586617     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext)    93cdd29d-9cb7-c0b7-30fc-036846fdf6e5
02/07/2017 22:23:09.72  w3wp.exe (0x4368)                           0x2600  SharePoint Portal Server        User Profiles                   cm6y    High        User Profile Application Proxy failed to retrieve partitions from User Profile Application: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have bdeb6d58-f138-4070-84af-f95d1d586617     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext)    93cdd29d-9cb7-c0b7-30fc-036846fdf6e5
02/07/2017 22:23:09.72  w3wp.exe (0x4368)                           0x1AF8  SharePoint Portal Server        User Profiles                   cm6y    High        User Profile Application Proxy failed to retrieve partitions from User Profile Application: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have bdeb6d58-f138-4070-84af-f95d1d586617     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext)    93cdd29d-9cb7-c0b7-30fc-0d1856d4ecfe
02/07/2017 22:23:09.72  w3wp.exe (0x4368)                           0x2600  SharePoint Portal Server        User Profiles                   cm6y    High        User Profile Application Proxy failed to retrieve partitions from User Profile Application: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have bdeb6d58-f138-4070-84af-f95d1d586617     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext)    93cdd29d-9cb7-c0b7-30fc-036846fdf6e5

so can anyone adivce on this problem? now the search is working as everything is being searched ,, but the full crawl is not ending ,, so new content will not get indexed unless i manually stop the running full crawl and re-run it again ..

  • John, what CU are you running on your farm? Are your sites ssl enabled? If yes then in that case you might need to change the sts4 protocol to sts4s. REF: digantakumar.com/2009/09/14/… – Marek Sarad Feb 8 '17 at 8:19
  • @MarekSarad thanks for the reply.. my current CU is 15.0.4797.1000 .. and the sites are not ssl enabled . – john Gu Feb 8 '17 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.