1

I am using SharePoint Server 2013 and I am facing some issues with opening the documents:

  • When I created a new Office file (Excel, word...) I received server error:

Create online documents error

  • when I opened the documents directly from a document library, I can do that normally. But, when I did a search and opened the document I received an error:

Open documents after search error

  • I cannot preview the document as shown below :

Preview document error

I did my researches and I think it's an Office Web Apps problem. I don't know even if it is installed or not since I am not the one who did the installation!!

Can someone help me?

I need to know how to check if the OWA is installed or not and if I need to install it and link it to SP

  • You can use Get-SPWOPIBinding on the server to at least identify the FQDN used to connect to WAC. You can then trace that back to the server which is running WAC. Note that WAC cannot be installed on a SharePoint server. – Trevor Seward Feb 6 '17 at 18:24
2

OfficeWebApps (OWA) always need to be installed on a separate Server. So we first have to find out where it is installed.

  • Execute Get-SPWopiBinding in a SharePoint Management Shell on your SharePoint Server. You will find your OWA-Hostname in the attribute ServerName

  • Execute Get-SPWopiZone. Note the protocol (HTTP or HTTPS)

  • Then connect to your OWA-Server, start a PowerShell as Administrator and enter Get-OfficeWebAppsFarm. This will display your OWA-Configuration.

  • Make sure, that the hostname in Internal URL matches the ServerName on your SharePoint WOPI-Binding. Please note that ServerName only shows a Hostname, no protocol (like HTTP oder HTTPS). This is OK! The Protocol must match the value of your WOPIZone.

Please post some screenshots if you need more help.

  • Thank you for your answer @MHeld ! I got the Server Name and the http protocol. However when I tried to connect to the OWA-Server using Get-OfficeWebAppsFarm , I got an error saying that the term Get- OfficeWebAppsFarm is not recognized as the name of the cmdlets. I tried to import the OWA module using Import-Module -Name OfficeWebApps but I got another error saying that the specified module was not loaded because no valid module file was found. I am sorry I couldn't insert the screenshots in the comment so you can understand my issues! – N.Sahraoui Feb 7 '17 at 10:03
  • Please make sure to execute the Get-OfficeWebAppsFarm on your OWA-Server, not on SharePoint. If you get the error on your OWA-Server, it seems that the product is no longer installed. You can check this in Installed Programs and features. – MHeld Feb 7 '17 at 10:27
  • Thanks @MHeld I will check and get back to you! I just want you to know that I tried ServerName/hosting/discovery and I got Server Error We're sorry. An error has occurred. We've logged the error for the server administrator – N.Sahraoui Feb 7 '17 at 10:34
  • I found the server on which the OWA is installed. But Should I execute the Get-OfficeWebAppsFarm on the windows powershell ? What about uninstalling it and reinstall it and start the configuration from scratch? – N.Sahraoui Feb 8 '17 at 17:01
  • 1
    Yes, Get-OfficeWebAppsFarm is a OfficeWebApps CMDlet. So please execute it on your OWA-Server and post the output. My recommendation depends on that. Thanks! – MHeld Feb 8 '17 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.