6

I have a SharePoint 2016 farm with only OOTB confugurated Web Application and Site Collection. On a specific list I've added a SharePoint Designer (SPD 2013) Workflow (2010). It does what it's supposed to do, updating properties on an item by a user.

The site collection and site is in Swedish locale (1053) and every list and item are in Swedish. Even the settings page is all in Swedish.

SharePoint Designer Actions are in Swedish

enter image description here

But when users browse to the Workflow form, the default InfoPath columns and buttons are in English, and my custom column (where user should add value) are in Swedish.

enter image description here

When I try to edit the form from SharePoint Designer,

enter image description here

I get some strange errors:

  1. enter image description here

  2. enter image description here

Googling the matter gives a few suggestions on settings in Central Administration, which I've changed accordingly

Configure InfoPath Forms Services

enter image description here

I've tried to install InfoPath 2010 (if that has something to do with it?), but am unable to install, since my MSDN subscription doesn't have that product key.

Still one would want this to be a language setting somewhere, which I've missed, so I don't have to edit the language on the form itself. Where is the language setting for SPD 2010 Workflows on InfoPath Forms?

5

Where is the language setting for SPD 2010 Workflows on InfoPath Forms?

Unfortunately, there is no option to change the Form language of InfoPath form via SharePoint Designer.

You just need to use Infopath Designer to edit the displayed language for default InfoPath form columns and button manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.