0

Hi everyone have an issue when attempt to access restful api through browser with basic request as picture below instead of xml result: enter image description here

it also occurs on CSOM the error returns : The remote server returned an error: (404) Not Found, anyone have faced with this problems, please help me.

4
  • What is URL of web application in Central Administrator? Your URL looks like you browse site from IIS directly. Commented Feb 4, 2017 at 17:08
  • it was http://[pc-name]:port , but it worked fine when i used localhost:port, just cannot browse to _api/web, the original url aslo Commented Feb 5, 2017 at 4:09
  • Can you please try with pc-name URL instead of localhost Commented Feb 5, 2017 at 5:37
  • regretfully, i have tried already but it still doesn't work :( Commented Feb 5, 2017 at 7:23

1 Answer 1

0

It has any problems when i get 401 error before it return 404 ? enter image description here

1
  • Do you have permission? It is related to permission related issue. Commented Feb 5, 2017 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.