0

Ok tried the ealier versions of spfx and had no issues. Thought I would try RC0 with samples but struggling to clone locally, both at work on home ( no proxy) on my dev laptop. Any ideas

λ git clone https://github.com/SharePoint/sp-dev-fx-webparts.git

Cloning into 'sp-dev-fx-webparts'... fatal: unable to access 'https://github.com/SharePoint/sp-dev-fx-webparts.git/': Failed to connect to 172.17.59.11 port 8080: Timed out

D:\Box Sync\yo λ ping 172.17.59.11

Pinging 172.17.59.11 with 32 bytes of data: Request timed out.

  • 1
    Everything works just fine for me. It's extremely rare situation if github is not available. Check your proxy\dns cache\internet. – Sergei Sergeev Feb 3 '17 at 10:09
  • Looks more like an internet connection/speed issue ? ISP block ? Works absolutely fine at my end. If you have any azure VM , try inside that. Check this image - i.stack.imgur.com/8zHxF.png – Gautam Sheth Feb 3 '17 at 10:10
  • I have tried with and without a proxy at work. I would think DNS and or timeout settings if the simple ping worked. Also disabled AV temporarily . GIT on Visual Studio Online works fine. Yes I could try Azure. – westerdaled Feb 3 '17 at 10:17
  • Got a mate near London to ping the ip address with an app on his phone called ping .. no response. he pinged his router and got a response. I am thinking this is a UK thing going on ... maybe country blocking - early Brexit ;-) – westerdaled Feb 3 '17 at 10:57
0

After thinking about it - the answer was obvious - I hadn't twigged that I was staring at the proxy address . Then I remembered having to set the proxy in Git for VC code when last connected to the proxy. Hence, just needed to undo this.

git config --global --unset http.proxy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.