1

We just migrated from SP 2010 on premise to Office365 with Sharepoint Online.

One thing I was accustomed to doing was to insert a Content Editor on the same page as a list so I could add directions and information about the list. I would simply create a new list and then "edit page" and I could add another webpart above the list.

However in SPO I don't see any commands to enter page edit mode for lists.

How do I enter page-edit mode for lists in SPO?

1

Lists and libraries in SharePoint online are by default opened in so called "New experience" mode, which doesn't allow us to do page customizations. In order to edit the page and add the Content Editor web part to it you could switch to the classic mode (there is a link in the lower left corner of the page).

You can read more about switching between the list modes here.

| improve this answer | |
  • Hey! You beat me to it - My boss walked into my office and I stopped to talk to him and whilst I was away from keyboard you posted what I had in my editor! – bgmCoder Feb 1 '17 at 21:49
  • :) I'm glad you solved the problem! – Damjan Tomic Feb 1 '17 at 21:51
  • I'll mark your answer in a moment... – bgmCoder Feb 1 '17 at 21:53
1

Ah - in the List Settings > Advanced Settings section, there is a section for List Experience with choices for Default,New Experience or Classic Experience.

Classic Experience makes it look somewhat like SP 2010 with the Ribbon - it brings back the Ribbon!

If you change this to Class Experience then you will have the option for Edit Page for the List.

The javascript command to enter Page Layout Mode is simply this: ChangeLayoutMode(false); but it doesn't work in the "New Experience" mode. It only works if you set the list to Classic mode.

Now, after you change the list to Classic Mode you will no longer see List Settings in the gear-button dropdown. You'll have to click in the list to pop open the ribbon and use the List Settings button in the Ribbon. The whole experience is not very consistent.

However, there is one more caveat that I've found. If you switch to Classic Experience and add a webpart (such as a Content Editor) you cannot switch back to New Experience as long as there are extra webparts on the page. Even if you change the setting again in List Settings > Advanced Settings - it just won't change back; the setting will stay set the way you mark it, but the display won't change. I guess New Experience is not capable of displaying other webparts.

One more thing to add: Say you do want it back to New Experience - and say you go and delete those extra webparts. Even if you left the setting set to New Experience you still have to go and change it again to make it take effect now that you've removed the webparts.

Enjoy!

| improve this answer | |
0

Everything above is correct. Another move that worked for me is this.

So in the new SPO experience; the home page gives you the most development experience... You always want to be doing all custom development in the homepage.. Making a new "list" is strictly for building the list. Making a new "page" is really just basic basic text content. I usually build a sub-site instead of "pages" and just put the link in the navigation bar. I typically avoid building "pages" in SPO as I don't find them useful.

But we want to put add directions and information about the list so we can see it when working on a list.

Here's what works for me 1. Make a "list" in the new experience and customize it however your want. 2. Goto the homepage and goto add a webpart > choose lists > choose that list you made. Now the list is displayed on a site that you can still edit the content/add webparts and you didn't need to switch to classic. Bonus - Since the list is made in the new experience; it still integrates with powerapps and power automate! Win / Win!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.