2

I have a custom SharePoint 2013 list that is set to only allow people with access to the list to view it. However, when entering the library, users can only see the documents that they uploaded.

I want to know how to disable this so that everybody with access to this library can view all of the documents in the library.

Note: When I go to Library settings > Advanced Settings > There isn't this option:

how to Set Permissions so that users can only see/edit thier own items on a list

1

You should check if the "Require documents to be checked out before they can be edited?" option is turned on for the document library. If that is the case, documents that are uploaded and not checked in can be viewed only by the users who uploaded them.

The solution for the above scenario is either to turn off the "Require documents to be checked out before they can be edited?" in versioning settings page, or to train the users to check in their documents when they want to share them with others.

The mentioned option can be turned on/off in Library Settings -> Versioning settings

  • I looked at the Versioning settings and this is what I have listed. Content Approval: No - Document Version History: Create major versions - Draft Item Security: Any user who can read items - Require Check Out: Yes. What exactly am I turning off? – GeneralChief Feb 1 '17 at 18:46
  • Set "Require documents to be checked out before they can be edited?" to No and it should be fine. – Damjan Tomic Feb 1 '17 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.