5

After installing the following Sharepoint updates:

SharePoint Server 2016 // KB3141486

SharePoint Server 2016 MUI/language patch // KB3141487

When I run Products Configuration Wizard I'm getting the following Error:

SharePoint Products Configuration Wizard version 16.0.4477.1000. Copyright (C) Microsoft Corporation 2016. All rights reserved.

Performing configuration task 1 of 4 Initializing SharePoint Products upgrade...

Waiting to get a lock to upgrade the farm.

Successfully initialized the SharePoint Products configuration.

Performing configuration task 2 of 4 Initiating the upgrade sequence...

Failed to initiate the upgrade sequence.

An exception of type Microsoft.SharePoint.Upgrade.SPUpgradeException was thrown. Additional exception information: One or more types failed to load. Please refer to the upgrade log for more details.

Total number of configuration settings run: 2

Total number of successful configuration settings: 1

Total number of unsuccessful configuration settings: 2

Successfully stopped the configuration of SharePoint Products. Configuration of SharePoint Products failed. Configuration must be performed before you use SharePoint Products. For further details, see the diagnostic log located at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\LOGS\PSCDiagnostics_2_1_2017_12_7_58_213_337116108.log and the application event log. PS C:\Users\bpopnikolov>

I've tried to find a solution online but I couldn't find anything that could help. Can anyone help me with this problem? Here is a LINK to the log file.

  • Can you provide the ULS log from the failure, or the Upgrade Error log file, which will be in the same directory? – Trevor Seward Feb 1 '17 at 16:51
2

Maybe this article applies also to your installation. The problem described in the article is for a new installation. But your error-messages and even the called methods apply 100% for your problem. To get even closer, you could check your ULS-Log for the mentioned error Error Exception: Could not load file or assembly ‘Microsoft.Data.Odata’

I would recommend you to try Workaround Method 1:

If the server where SharePoint Server 2016 is installed is connected to the internet, then use the PrerequisiteInstaller.exe to download the necessary prerequisites component using the prerequisite installer. “Microsoft WCF Data Services 5.6” component that was installed using the PrerequisiteInstaller.exe is not affected by this issue.

  • This actually worked. After checking the Server logs I found that there was a problem with Microsoft.Data.Odata. I uninstalled it and run the PrerequisiteInstaller.exe again. It installed Microsoft WCF Data Services 5.6 and the configuration finished successfully. Tnx for the help! – Borislav Popnikolov Feb 2 '17 at 10:07
3

When you get this error, try using PowerShell to run SharePoint Products Configuration Wizard (PSConfig) with the following script:

PSConfig.exe -cmd upgrade -inplace b2b -wait -force -cmd applicationcontent -install -cmd installfeatures -cmd secureresources

If that doesn't work, you may need to run

Get-SPProduct -local

which will reset the configuration cache of the server. When you're done, run the PSConfig script again.

  • I was already running the Config Wizard through PowerShell with the following command PSCONFIG -cmd upgrade -inplace b2b -wait -force​ I tried running the one you posted but still no success. – Borislav Popnikolov Feb 1 '17 at 12:20
  • @BorislavPopnikolov I've updated my answer with Get-SPProduct script – Benny Skogberg Feb 1 '17 at 12:25
  • @BennySkogberd I've done all you've said and still the same error. – Borislav Popnikolov Feb 1 '17 at 12:33
  • Strange. And you've restarted the server already, I guess. Then I'm out of clues :( – Benny Skogberg Feb 1 '17 at 12:40
  • 1
    @BennySkogberg fyi Get-SPProducts -Local is no longer necessary on the latest SharePoint 2016 patches. – Trevor Seward Feb 1 '17 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.