5

The problem: I dont see 'All files' in Sharepoint Designer:'

I have full administrator rights of whole Sharepoint.

When I open:

mySPwebsite.com/teams/sandbox/Gedeelde%20%20documenten/Forms/

I do see the All files option.

But, when I open:

mySPwebsite.com/teams/Bedrijfsvoering/Verkoop/Documenten/Forms/

I don't see the All files option.

What is going on?

Thank you!

| improve this question | | | | |
  • I might be using the wrong terms, at the web application level, I have 'enabled managing of the Web Site URL Structure' enabled in central admin, when I connect to this site 'All files' shows up, however within this same web application I have multiple site collections that when I connect to, open new windows of SharePoint Designer, these site collections are missing the 'All files' options. How do I get 'All Files' to show up? – Leanne Jan 17 '19 at 21:05
11

The solution is simple:

When you enable SharePoint Designer at the web app level (by selecting the first checkbox to Enable SharePoint Designer), if you want the user to see the All Files menu item, make sure to also check the checkbox for Enable Managing of the Web Site URL Structure.

In central administration -> Select Web Application -->General Application Settings -> Sharepoint Designer

click on the Sharepoint Designer Settings option.

| improve this answer | | | | |
  • Hi Sam, you again :) " when you enable SPDesigner at the web app level " where is this option? – Bas Jan 31 '17 at 11:22
  • Please check my edited answer. – Samir Khimani Jan 31 '17 at 11:27
  • This? imgur.com/a/HmL4G – Bas Jan 31 '17 at 12:26
  • Yes, Select last one option and check please. – Samir Khimani Jan 31 '17 at 12:28
  • ITS WORKING! :) – Bas Jan 31 '17 at 12:28
0

In addition to Samir's answer, you can also enable the "All Files" option by doing the following:

  1. Open your site in SharePoint Designer 2013.
  2. Click Site Options on the ribbon.
  3. Change the value of showurlstructure to 1.

enter image description here

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.