On final migration day, I'll be removing the name from our old WSS 3.0 server (http://sharepoint.domain.com) and placing it on our SharePoint 2010 server. I'd still like to be able to access our old server at a URL just in case there are issues. I tried to Extend the Web App on our WSS 3.0 server, however, Service Unavailable was reported for all URLs (old & new). I got it working (with help from this forum - thank you!) but not with the Extended Web App in place. Had to back it out. Is there another way to access the server (perhaps using server name & port?) or do I need to set aside some server downtime where I can troubleshoot the Extended Web App/Service Unavailable issue?

Thanks in advance!

1 Answer 1


There is actually a pretty simple solution. Merely have your DNS folks whip up a new DNS entry (like http://sharepoint07.domain.com - note the 07 in there), point that to your current 07 server and then add that as the URL for one of your Zones in your Alternate Access Mappings( I.E. Intranet/Internet/Extranet/Custom).

When the migration happens, http://sharepoint.domain.com can move over to 2010 without any fuss and you can continue to access your 07 site on the new http://sharepoint07.domain.com url for as long as it is needed.

If you have fiddled with the settings in IIS, you may need to also add the sharepoint07.domain.com as one of the valid host headers for your SP 07 site.

  • Nice!! Thanks. So it's not necessary to "Extend the Web App" as well?
    – user4747
    Commented Oct 4, 2011 at 13:28
  • Correct. The Alternate Access Mapping handles what it sounds like you were attempting to do by extending the web app.
    – Dave Wise
    Commented Oct 5, 2011 at 19:59
  • First off - thanks fo much for your replies. And after I put more thought into it, I'm unsure how this will work for our setup. Under AAM, I have two URLs - one for CA and one for our only Web App sharepoint.domain.com under Internal URL, Zone is Default and Public URL is sharepoint.domain.com. If I setup another, doesn't it have to point to sharepoint.domain.com (which will disappear on final migration day). My apologies for not giving enough detail originally.
    – user4747
    Commented Oct 6, 2011 at 13:55
  • 1
    The sharepoint07.domain.com url needs to be defined as the default url for one of your zones. If it is simply an AAM to your sharepoint.domain.com then it will do the behavior you are seeing.
    – Dave Wise
    Commented Oct 12, 2011 at 1:56
  • 1
    Click on "Edit Public URLs" and then add your SharePoint2007.domain.com url to one of the blank zones, i.e. Extranet. Once you've done that, you should be able to use either URL to access your site
    – Dave Wise
    Commented Oct 20, 2011 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.