2

I have installed and configured Workflow manager using Microsoft Web Platform installer. The configuration is showing as accurate and the workflow service application shows that it is connected but SharePoint Designer 2013 will not recognize it. I have tried uninstalling SharePoint designer, patching both the service bus and workflow manager client, verified permissions and ensured that the farm is set to allow 2013 workflows but still no dice.

Thoughts?

0

Make sure that the workflow application service proxy has been connected to your web application by doing the following:

  • Open Central Administration.
  • Application Management > Service Application > Configure Service Application Associations.
  • Make sure that your web application is connected to Workflow Service Application Proxy.
  • If it's not connected that mean you use a custom application proxy group.
    • So click on custom and check Workflow Service Application Proxy.
  • Or go to application management > manage web application >
    • Select your web application > from the above ribbon select service connection.
    • Check the Workflow Service Application Proxy.

Also, review your workflow manager installation steps as mentioned at Install and Configure Workflow Manager for SharePoint 2013

  • I went through and double checked. The Workflow application service proxy is part of the default group. – jw1317 Jan 30 '17 at 16:36
  • i am also seeing this in the upgrade log: Error UpgradeWorkflowServiceActivities. Run Copy-SPLocalActivitiesToWorkflowService manually to complete this action. I followed the steps but didn't fix the issue – jw1317 Jan 30 '17 at 16:36
  • are you checked your application proxy ? what's its type ? default or custom – Mohamed El-Qassas MVP Jan 30 '17 at 16:38
  • it's set to default – jw1317 Jan 30 '17 at 18:32
0

Have you register your site collection with workflow manager server? Please check below link.

https://technet.microsoft.com/en-in/library/jj663115.aspx

  • Sam, thanks for the reply. I followed the guide to the letter for the install – jw1317 Jan 30 '17 at 16:37
0

Can you validate your installation as described here https://technet.microsoft.com/en-us/library/jj658588.aspx#section6

  1. ensure the Workflow Services & Workflow Web Application (in IIS) is running.
  2. Check what you get in ULS logs.
  3. ensure the feature is enabled

    Enable-SPFeature -Identity WorkflowServiceStore –Url $yourUrl

Re-register the Workflow

Register-SPWorkflowService -SPSite "<URLofTheSharepointWebApp>" -WorkflowHostUri "https://URLOFWORKFLOWAP:12290/" -ScopeName "<EnterNameOfScope use this example "DevMachiene2">" -AllowOAuthHttp -force 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.