1

I have been trying to add a new custom search refiner using a column looking at managed metadata and I'm just not seeing any results. I have highlighted the steps I have taken below:

  • Created new term set in Admin centre
  • Created site column looking using new term set in another site collection
  • Populated documents with that new column and reindexed library
  • Assigned new column to 'RefinableString01' in Admin centre
  • Reindexed Search site and Root site just to be sure
  • Added 'RefinableString01' to the search refiner panel template

I looked at a number of different guides to implement if this. Am I missing something?

The only thing I believe is questionable is the fact that the column is looking at managed metadata whereas most columns are not when i've been reading through instructions.

Any help would be much appreciated!

Update showing refinement configRefinement config

  • I have still not been able to resolve this issue. Interestingly, I have followed the same steps but instead of using a managed metadata column from the term store, I used a standard choice column and this worked. So it would appear the issue is specifically around the fact it's using a Managed Metadata column - but that would insane not be able to use Managed Metadata columns as search refiners? – kelly slack Mar 1 '17 at 10:18
0

Whenever you map a site column of taxonomy type to refiner, there are 2 options, ows_sitecolumnName and ows_taxId_sitecolumnName as below:

enter image description here

I always, map it to the ows_sitecolumnName as below and it works for me.

enter image description here

After mapping this, just reindex the site where column is present. Should work now.

  • Thanks. This is the property I had mapped and still not picking anything up when doing a search query on it :S – kelly slack Jan 27 '17 at 13:57
  • Ok , to debug, on a test page, just add search results webpart and the refiners webpart. In the refiner webpart, add you refinable string. Check if the value is present there or not ? Also ,can you post the query you are using ? Could be some issue with syntax ? – Gautam Sheth Jan 27 '17 at 13:59
  • I created a blank page and added the standard search web parts and it just does not pick anything up. It appears the refinablestring isn't picking up any results (see updated post for screenshot) – kelly slack Feb 6 '17 at 9:45
  • Did you configure the query correctly ? – Gautam Sheth Feb 6 '17 at 10:09
  • Sorry I don't know what you mean by this, I haven't set up a query anywhere at this stage? – kelly slack Feb 6 '17 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.