3

In a library I have a problem with a workflow triggered on creation. The workflow simply sends an email to a user and does not modify the documents neither the meta-information, but when I upload a document and have filled the requested info in the popup form, I get an error that the document has been modified by myself.

Does anybody knows a workaround for this?

Some picture to make it clear: At file loading I have the meta info form....

But at saving... enter image description here

On request I am adding also the workflow picture. enter image description here

  • I have understood that the workflow itself is changing the meta-information on its column "WorkflowName" at the very beginning. I have tried deleting this column but it made workflow loosing its connection with the list... it runs forever without conclusion. :( – Marpio Jan 26 '17 at 10:37
  • how have u built your workflow? can we have a look at it (picture)? – Melad Batta Jan 26 '17 at 12:50
  • Yes. Adding WF pitcure in the Body, but I don't think it helps. Any workflow would have the same effect – Marpio Jan 26 '17 at 12:59
  • Change it to be an on change workflow instead of an on creation and you'll be all set – Eric Alexander Jan 26 '17 at 14:03
  • Eric, I need this to be run on new items, otherwise I would have done it differently! – Marpio Jan 26 '17 at 14:09
2

I Have found the solution. And it is very trivial...
It's enough to prevent the Workflow writing the stage name! So I just had to untick this enter image description here ...and my workflow does not change the item anymore!
Can anybody sign this as solution? I cannot do it for it is my own answer...

0

Make it go into a loop that will wait X minutes until there is a Main-Category added, that way it won't change anything until after people have uploaded and set the metadata.

  • This was the aim I had when giving the pause, but the problem is that when any WF is started - even if it just loops - a column is changed in the item... – Marpio Jan 27 '17 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.