0

I've got an awkward issue with inline search on document libraries for one particular client - looking for any ideas/help on this as it's been bugging us for months now, and the workaround we tried won't work either.

The library has a folder structure like below:

Library root

Finance

Regions

Region specific folders (US, EMEA, APAC etc)

If you do an inline search (i.e. the small search box under the New Document etc links - someone correct me if that's the wrong term) while inside one of the subfolders, the results come back from ALL folders, and also show all the folders back up the chain. So if we search for a file in EMEA, we'll see matching results from every folder, as well as any folder containing a matching file, it's parent folder, it's parent, and so on.

I tried it on another SP2013 farm and replicated the folder structure, but on this one it works as expected - if you search within a subfolder the initial results are scoped to that subfolder, and you only get the full results if you click the 'Some items may be hidden. Include them in your search' link.

So from what I can see the first farm is skipping straight to what you'd get by clicking the 'Some items may be hidden' option. As far as I know there is no custom code in play and search settings look normal (the site has it's own search center as a subsite); everything else search-related on the site works fine, including a custom vertical scoped against a content type.

The farm where it doesn't work is on the September 2015 CU (15.0.4753.1003) and the one where it does work is on 15.0.4569.1506 - the issue did get reported a short while after I patched the farm, but I'd ideally need to check on a third farm of at least the Sept 15 CU to confirm if the patch has introduced the problem.

Any ideas?

  • 4569 was not to be installed, toddklindt.com/blog/Lists/Posts/Post.aspx?ID=486 – Eric Alexander Jan 18 '17 at 17:03
  • Okay but that doesn't really help me... the farm already had that patch installed when it was handed over to us for support by the company that built it. It also doesn't explain why if that patch was not to be installed the farm with it exhibits the correct behavior, but the one with a later patch doesn't. – Thomas Gass Jan 19 '17 at 11:01
0

Have checked this on a third farm now and it would seem that as suspected this is an issue after applying the September 2015 CU (15.0.4753.1003). The question remains now however at what patch level is this behavior reversed...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.